summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-07-21 19:49:04 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-07-21 19:49:04 +0000
commitfa8cebabc8ca4536657688bdd75102ae66465d34 (patch)
treea5256eb6cb14b51e2dbce13099bcd4722f6336bb
parentstable x86, bug 275593 (diff)
downloadgentoo-2-fa8cebabc8ca4536657688bdd75102ae66465d34.tar.gz
gentoo-2-fa8cebabc8ca4536657688bdd75102ae66465d34.tar.bz2
gentoo-2-fa8cebabc8ca4536657688bdd75102ae66465d34.zip
Version bump to 1.24.5 . Fix two crashes and one invalid weak reference
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/pango-1.24.5.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index d28cbd9052f3..c97b756bd1a3 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.260 2009/07/09 17:32:31 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.261 2009/07/21 19:49:04 mrpouet Exp $
+
+*pango-1.24.5 (22 Jul 2009)
+
+ 22 Jul 2009; Romain Perier <mrpouet@gentoo.org> +pango-1.24.5.ebuild:
+ Version bump to 1.24.5 . Fix two crashes and one invalid weak reference
09 Jul 2009; Romain Perier <mrpouet@gentoo.org>
pango-1.24.4.ebuild:
diff --git a/x11-libs/pango/pango-1.24.5.ebuild b/x11-libs/pango/pango-1.24.5.ebuild
new file mode 100644
index 000000000000..b77a31ec7cba
--- /dev/null
+++ b/x11-libs/pango/pango-1.24.5.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.24.5.ebuild,v 1.1 2009/07/21 19:49:04 mrpouet Exp $
+
+EAPI="2"
+
+inherit eutils gnome2 multilib
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X doc"
+
+# FIXME: add gobject-introspection dependency when it is available
+RDEPEND="dev-libs/glib:2
+ >=media-libs/fontconfig-2.5.0
+ media-libs/freetype:2
+ >=x11-libs/cairo-1.7.6[X?,svg]
+ X? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ X? ( x11-proto/xproto )"
+
+DOCS="AUTHORS ChangeLog* NEWS README THANKS"
+
+function multilib_enabled() {
+ has_multilib_profile || ( use x86 && [ "$(get_libdir)" = "lib32" ] )
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with X x)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system. Fix building for
+ # emul-linux-x86-gtklibs
+ if multilib_enabled ; then
+ epatch "${FILESDIR}/${PN}-1.2.5-lib64.patch"
+ fi
+
+ # gtk-doc checks do not pass, upstream bug #578944
+ sed 's:TESTS = check.docs: TESTS = :g'\
+ -i docs/Makefile.am docs/Makefile.in || die "sed failed"
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ] ; then
+ einfo "Generating modules listing..."
+
+ local PANGO_CONFDIR=
+
+ if multilib_enabled ; then
+ PANGO_CONFDIR="/etc/pango/${CHOST}"
+ else
+ PANGO_CONFDIR="/etc/pango"
+ fi
+
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}