diff options
author | Sebastien Fabbro <bicatali@gentoo.org> | 2008-04-29 14:55:53 +0000 |
---|---|---|
committer | Sebastien Fabbro <bicatali@gentoo.org> | 2008-04-29 14:55:53 +0000 |
commit | fa7885445d60b30a30833a7bc0a2b626020715aa (patch) | |
tree | 423a09f3201798ec12cc3a20492cc60ffc83dbdb | |
parent | Version bump (diff) | |
download | gentoo-2-fa7885445d60b30a30833a7bc0a2b626020715aa.tar.gz gentoo-2-fa7885445d60b30a30833a7bc0a2b626020715aa.tar.bz2 gentoo-2-fa7885445d60b30a30833a7bc0a2b626020715aa.zip |
Version bump. Separated patches for fit plugins and qtiplot.pro for better re-usability
(Portage version: 2.1.5_rc6)
-rw-r--r-- | sci-visualization/qtiplot/ChangeLog | 13 | ||||
-rw-r--r-- | sci-visualization/qtiplot/files/qtiplot-0.9.3-homepage.patch | 11 | ||||
-rw-r--r-- | sci-visualization/qtiplot/files/qtiplot-0.9.5-fitplugins.patch | 34 | ||||
-rw-r--r-- | sci-visualization/qtiplot/files/qtiplot-0.9.5-profile.patch (renamed from sci-visualization/qtiplot/files/qtiplot-0.9.3-systemlibs.patch) | 71 | ||||
-rw-r--r-- | sci-visualization/qtiplot/qtiplot-0.7.7.ebuild | 4 | ||||
-rw-r--r-- | sci-visualization/qtiplot/qtiplot-0.9.4.ebuild | 8 | ||||
-rw-r--r-- | sci-visualization/qtiplot/qtiplot-0.9.5.ebuild (renamed from sci-visualization/qtiplot/qtiplot-0.9.3.ebuild) | 31 |
7 files changed, 73 insertions, 99 deletions
diff --git a/sci-visualization/qtiplot/ChangeLog b/sci-visualization/qtiplot/ChangeLog index 5f2c08823767..f7836281bf46 100644 --- a/sci-visualization/qtiplot/ChangeLog +++ b/sci-visualization/qtiplot/ChangeLog @@ -1,6 +1,17 @@ # ChangeLog for sci-visualization/qtiplot # Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.20 2008/03/28 18:30:44 bicatali Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/ChangeLog,v 1.21 2008/04/29 14:55:52 bicatali Exp $ + +*qtiplot-0.9.5 (29 Apr 2008) + + 29 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org> + -files/qtiplot-0.9.3-homepage.patch, + -files/qtiplot-0.9.3-systemlibs.patch, + +files/qtiplot-0.9.5-fitplugins.patch, +files/qtiplot-0.9.5-profile.patch, + qtiplot-0.7.7.ebuild, -qtiplot-0.9.3.ebuild, qtiplot-0.9.4.ebuild, + +qtiplot-0.9.5.ebuild: + Version bump. Separated patches for fit plugins and qtiplot.pro for better + re-usability *qtiplot-0.9.4 (28 Mar 2008) diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.3-homepage.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.3-homepage.patch deleted file mode 100644 index 12a9ebd1288e..000000000000 --- a/sci-visualization/qtiplot/files/qtiplot-0.9.3-homepage.patch +++ /dev/null @@ -1,11 +0,0 @@ ---- qtiplot/src/main.cpp.orig -+++ qtiplot/src/main.cpp -@@ -45,7 +45,7 @@ - <br> - - The QtiPlot web page can be found at<br> -- <a href="http://soft.proindependent.com/qtiPlot.html">http://soft.proindependent.com/qtiPlot.html</a><br> -+ <a href="http://soft.proindependent.com/qtiplot.html">http://soft.proindependent.com/qtiplot.html</a><br> - - \section libs QtiPlot uses the following libraries: - <a href="http://www.trolltech.com/products/qt/index.html">Qt</a>, diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.5-fitplugins.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.5-fitplugins.patch new file mode 100644 index 000000000000..5eb0bec52850 --- /dev/null +++ b/sci-visualization/qtiplot/files/qtiplot-0.9.5-fitplugins.patch @@ -0,0 +1,34 @@ +--- fitPlugins/fitRational0/fitRational0.pro.orig 2008-03-06 15:11:53.000000000 +0000 ++++ fitPlugins/fitRational0/fitRational0.pro 2008-03-06 15:16:28.000000000 +0000 +@@ -12,12 +12,10 @@ + DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += /usr/include/gsl
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
+--- fitPlugins/fitRational1/fitRational1.pro.orig 2008-03-06 15:13:35.000000000 +0000 ++++ fitPlugins/fitRational1/fitRational1.pro 2008-03-06 15:16:52.000000000 +0000 +@@ -12,12 +12,10 @@ + DESTDIR = ../
+
+ # statically link against GSL in 3rdparty
+-INCLUDEPATH += ../../3rdparty/gsl/include/
+-LIBS += ../../3rdparty/gsl/lib/libgsl.a
+-LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
++INCLUDEPATH += /usr/include/gsl
+
+ #dynamically link against GSL installed system-wide
+-#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
++unix:LIBS += $$system(pkg-config --libs gsl)
+
+ target.path=/usr/lib$${libsuff}/qtiplot/plugins
+ INSTALLS += target
diff --git a/sci-visualization/qtiplot/files/qtiplot-0.9.3-systemlibs.patch b/sci-visualization/qtiplot/files/qtiplot-0.9.5-profile.patch index ef09eb057a8f..9bb8957130b1 100644 --- a/sci-visualization/qtiplot/files/qtiplot-0.9.3-systemlibs.patch +++ b/sci-visualization/qtiplot/files/qtiplot-0.9.5-profile.patch @@ -1,17 +1,6 @@ ---- qtiplot/qtiplot.pro.orig 2008-03-06 15:02:08.000000000 +0000 -+++ qtiplot/qtiplot.pro 2008-03-06 21:57:33.000000000 +0000 -@@ -16,8 +16,8 @@ - # comment the following lines if you haven't subscribed for a QtiPlot binaries maintenance contract
- #RESTRICTED_MODULES += EMF
-
--#CONFIG += release
--CONFIG += debug
-+CONFIG += release
-+#CONFIG += debug
- #win32: CONFIG += console
-
- # what to install and where
-@@ -45,12 +45,12 @@ +--- qtiplot/qtiplot.pro.orig 2008-04-24 18:54:47.622675411 +0000 ++++ qtiplot/qtiplot.pro 2008-04-24 19:01:18.639824832 +0000 +@@ -30,12 +30,11 @@ #!!! Warning: You must modify these paths according to your computer settings
#############################################################################
@@ -26,11 +15,10 @@ +INCLUDEPATH += /usr/include/qwt5
+INCLUDEPATH += /usr/include/liborigin
+INCLUDEPATH += /usr/include/gsl
-+ ##################### 3rd PARTY LIBRARIES SECTION ###########################
#!!! Warning: You must modify these paths according to your computer settings
-@@ -59,17 +59,19 @@ +@@ -44,17 +43,19 @@ ##################### Linux (Mac OS X) ######################################
# statically link against libraries in 3rdparty
@@ -59,28 +47,17 @@ ##################### Windows ###############################################
-@@ -124,8 +126,8 @@ - translations/qtiplot_ja.ts \
- translations/qtiplot_sv.ts
-
--#system(lupdate -verbose qtiplot.pro)
--#system(lrelease -verbose qtiplot.pro)
-+system(lupdate -verbose qtiplot.pro)
-+system(lrelease -verbose qtiplot.pro)
-
- translations.files += translations/qtiplot_de.qm \
- translations/qtiplot_es.qm \
-@@ -139,8 +141,7 @@ +@@ -147,8 +148,7 @@ manual.files += ../manual/html \
../manual/qtiplot-manual-en.pdf
-documentation.files += ../README.html \
- ../gpl_licence.txt
-+documentation.files += ../README.html
++documentation.files += ../README.html
unix: man.files += ../qtiplot.1
-@@ -395,8 +396,8 @@ +@@ -403,8 +403,8 @@ ################# Origin Import (liborigin) ###################
###############################################################
@@ -91,37 +68,3 @@ ###############################################################
################# Module: Plot 2D #############################
---- fitPlugins/fitRational0/fitRational0.pro.orig 2008-03-06 15:11:53.000000000 +0000 -+++ fitPlugins/fitRational0/fitRational0.pro 2008-03-06 15:16:28.000000000 +0000 -@@ -12,12 +12,10 @@ - DESTDIR = ../
-
- # statically link against GSL in 3rdparty
--INCLUDEPATH += ../../3rdparty/gsl/include/
--LIBS += ../../3rdparty/gsl/lib/libgsl.a
--LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
-+INCLUDEPATH += /usr/include/gsl
-
- #dynamically link against GSL installed system-wide
--#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
-+unix:LIBS += $$system(pkg-config --libs gsl)
-
- target.path=/usr/lib$${libsuff}/qtiplot/plugins
- INSTALLS += target
---- fitPlugins/fitRational1/fitRational1.pro.orig 2008-03-06 15:13:35.000000000 +0000 -+++ fitPlugins/fitRational1/fitRational1.pro 2008-03-06 15:16:52.000000000 +0000 -@@ -12,12 +12,10 @@ - DESTDIR = ../
-
- # statically link against GSL in 3rdparty
--INCLUDEPATH += ../../3rdparty/gsl/include/
--LIBS += ../../3rdparty/gsl/lib/libgsl.a
--LIBS += ../../3rdparty/gsl/lib/libgslcblas.a
-+INCLUDEPATH += /usr/include/gsl
-
- #dynamically link against GSL installed system-wide
--#unix:LIBS += -L /usr/lib$${libsuff} -lgsl -lgslcblas
-+unix:LIBS += $$system(pkg-config --libs gsl)
-
- target.path=/usr/lib$${libsuff}/qtiplot/plugins
- INSTALLS += target
diff --git a/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild b/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild index d1097ca60b7d..5520d0d1370b 100644 --- a/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild +++ b/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild @@ -1,6 +1,6 @@ # Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild,v 1.4 2008/02/13 14:33:59 markusle Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.7.7.ebuild,v 1.5 2008/04/29 14:55:52 bicatali Exp $ inherit eutils multilib qt3 @@ -14,7 +14,7 @@ KEYWORDS="amd64 ~x86" IUSE="bindist" RDEPEND="$(qt_min_version 3.3) - >=x11-libs/qwt-4.2.0 + <x11-libs/qwt-5 <x11-libs/qwtplot3d-0.2.7 !bindist? ( sci-libs/gsl ) bindist? ( <sci-libs/gsl-1.10 )" diff --git a/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild index e4e797599463..4780c8f5ead6 100644 --- a/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild +++ b/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild @@ -1,6 +1,6 @@ # Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild,v 1.1 2008/03/28 18:30:44 bicatali Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.4.ebuild,v 1.2 2008/04/29 14:55:52 bicatali Exp $ inherit eutils multilib qt4 @@ -26,7 +26,7 @@ CDEPEND=">=x11-libs/qwt-5.0.2 !bindist? ( sci-libs/gsl ) bindist? ( <sci-libs/gsl-1.10 )" -DEPEND="${RDEPEND} +DEPEND="${CDEPEND} dev-util/pkgconfig python? ( >=dev-python/sip-4.5.2 )" @@ -36,8 +36,6 @@ RDEPEND="${CDEPEND} dev-python/pygsl sci-libs/scipy )" -QT4_BUILT_WITH_USE_CHECK="qt3support" - src_unpack() { unpack ${A} cd "${S}" @@ -45,7 +43,7 @@ src_unpack() { # docs: remove default doc building sed -i -e '/manual/d' qtiplot.pro qtiplot/qtiplot.pro \ - || die "die sed for docs failed" + || die "sed for docs failed" sed -i -e "s:doc/${PN}:doc/${PF}:" qtiplot/qtiplot.pro if ! use python; then diff --git a/sci-visualization/qtiplot/qtiplot-0.9.3.ebuild b/sci-visualization/qtiplot/qtiplot-0.9.5.ebuild index 302ac051ff8c..78f046c55fe2 100644 --- a/sci-visualization/qtiplot/qtiplot-0.9.3.ebuild +++ b/sci-visualization/qtiplot/qtiplot-0.9.5.ebuild @@ -1,7 +1,8 @@ # Copyright 1999-2008 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 -# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.3.ebuild,v 1.2 2008/03/15 11:16:35 corsair Exp $ +# $Header: /var/cvsroot/gentoo-x86/sci-visualization/qtiplot/qtiplot-0.9.5.ebuild,v 1.1 2008/04/29 14:55:52 bicatali Exp $ +EAPI="1" inherit eutils multilib qt4 DESCRIPTION="Qt based clone of the Origin plotting package" @@ -26,7 +27,7 @@ CDEPEND=">=x11-libs/qwt-5.0.2 !bindist? ( sci-libs/gsl ) bindist? ( <sci-libs/gsl-1.10 )" -DEPEND="${RDEPEND} +DEPEND="${CDEPEND} dev-util/pkgconfig python? ( >=dev-python/sip-4.5.2 )" @@ -36,24 +37,22 @@ RDEPEND="${CDEPEND} dev-python/pygsl sci-libs/scipy )" -QT4_BUILT_WITH_USE_CHECK="qt3support" - src_unpack() { unpack ${A} cd "${S}" - epatch "${FILESDIR}"/${P}-systemlibs.patch - epatch "${FILESDIR}"/${P}-homepage.patch + epatch "${FILESDIR}"/${P}-profile.patch + epatch "${FILESDIR}"/${P}-fitplugins.patch - # docs: remove default doc building - sed -i -e '/manual/d' qtiplot.pro qtiplot/qtiplot.pro \ - || die "die sed for docs failed" - sed -i -e "s:doc/${PN}:doc/${PF}:" qtiplot/qtiplot.pro + sed -i \ + -e '/manual/d'\ + -e '/3rd/d' \ + qtiplot.pro || die "sed qtiplot.pro failed" if ! use python; then sed -i \ -e '/^SCRIPTING_LANGS += Python/d' \ -e '/sipcmd/d' \ - ${PN}/${PN}.pro || die "sed for python option failed" + qtiplot/qtiplot.pro || die "sed for python option failed" fi # the lib$$suff did not work in the fitRational*.pro files @@ -66,7 +65,7 @@ src_unpack() { if ! use linguas_${l}; then sed -i \ -e "s:translations/qtiplot_${l}.ts::" \ - ${PN}/${PN}.pro || die + qtiplot/qtiplot.pro || die fi done } @@ -84,14 +83,14 @@ src_install() { doman qtiplot.1 || die "doman failed" if use doc; then - insinto /usr/share/doc/${PF} - doins -r "${WORKDIR}"/qtiplot-manual-en \ + insinto /usr/share/doc/${PF}/html + doins -r "${WORKDIR}"/qtiplot-manual-en/* \ || die "install manual failed" fi if use python; then - cd "${S}"/${PN} insinto /etc - doins qtiplotrc.py qtiUtil.py || die + doins qtiplot/{qtiplotrc,qtiUtil}.py \ + || die "install python config failed" fi } |