summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-07-12 14:31:24 +0000
committerDirkjan Ochtman <djc@gentoo.org>2015-07-12 14:31:24 +0000
commitf8bf6ef2af5c82d2ae5139531b7d136cc187dcef (patch)
tree00074cdda3c67f771249af06de907806dcf3bf10
parentdrop old vulnerables, bug 553664 (diff)
downloadgentoo-2-f8bf6ef2af5c82d2ae5139531b7d136cc187dcef.tar.gz
gentoo-2-f8bf6ef2af5c82d2ae5139531b7d136cc187dcef.tar.bz2
gentoo-2-f8bf6ef2af5c82d2ae5139531b7d136cc187dcef.zip
Version bump pelican to 3.6.0
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 30380381)
-rw-r--r--app-text/pelican/ChangeLog7
-rw-r--r--app-text/pelican/pelican-3.6.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index e86758e483f0..0326acb9d818 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.23 2015/06/07 08:12:33 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.24 2015/07/12 14:31:24 djc Exp $
+
+*pelican-3.6.0 (12 Jul 2015)
+
+ 12 Jul 2015; Dirkjan Ochtman <djc@gentoo.org> +pelican-3.6.0.ebuild:
+ Version bump pelican to 3.6.0
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/app-text/pelican/pelican-3.6.0.ebuild b/app-text/pelican/pelican-3.6.0.ebuild
new file mode 100644
index 000000000000..6636d072133d
--- /dev/null
+++ b/app-text/pelican/pelican-3.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.6.0.ebuild,v 1.1 2015/07/12 14:31:24 djc Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files"
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( README.rst )
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)
+
+#python_test() {
+# esetup.py test
+#}