summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-24 10:08:18 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-24 10:08:18 +0000
commitf8b9df060ba9e0e183cfd72dfcf4fb7a03754904 (patch)
tree6c627d1e3f1a7e351bbb7379f315b31e798d9559
parentLink in libz for pciutils #163563 by Tristan Heaven. (diff)
downloadgentoo-2-f8b9df060ba9e0e183cfd72dfcf4fb7a03754904.tar.gz
gentoo-2-f8b9df060ba9e0e183cfd72dfcf4fb7a03754904.tar.bz2
gentoo-2-f8b9df060ba9e0e183cfd72dfcf4fb7a03754904.zip
Add patch to make it compile with tvision-2.1.0, thanks to truedfx <truedfx at gentoo dot org> for the patch, bug 146465
(Portage version: 2.1.2-r2)
-rw-r--r--net-p2p/ldcc/ChangeLog9
-rw-r--r--net-p2p/ldcc/files/digest-ldcc-2.0.72
-rw-r--r--net-p2p/ldcc/files/ldcc-2.0.7-tvision2.1.0.patch102
-rw-r--r--net-p2p/ldcc/ldcc-2.0.7.ebuild13
4 files changed, 122 insertions, 4 deletions
diff --git a/net-p2p/ldcc/ChangeLog b/net-p2p/ldcc/ChangeLog
index 8a75b36155c5..840cc5e65779 100644
--- a/net-p2p/ldcc/ChangeLog
+++ b/net-p2p/ldcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ldcc
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ldcc/ChangeLog,v 1.7 2005/02/06 01:24:13 blubb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ldcc/ChangeLog,v 1.8 2007/01/24 10:08:18 armin76 Exp $
+
+ 24 Jan 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/ldcc-2.0.7-tvision2.1.0.patch, ldcc-2.0.7.ebuild:
+ Add patch to make it compile with tvision-2.1.0, thanks to truedfx <truedfx
+ at gentoo dot org> for the patch, bug 146465
06 Feb 2005; Simon Stelling <blubb@gentoo.org> ldcc-2.0.7.ebuild:
added ~amd64
diff --git a/net-p2p/ldcc/files/digest-ldcc-2.0.7 b/net-p2p/ldcc/files/digest-ldcc-2.0.7
index d23edbaea22f..a45390797764 100644
--- a/net-p2p/ldcc/files/digest-ldcc-2.0.7
+++ b/net-p2p/ldcc/files/digest-ldcc-2.0.7
@@ -1 +1,3 @@
MD5 1fbaa46a139880c6a91faf3dc5e678ff ldcc-2.0.7.tgz 74060
+RMD160 b9ff65a3af53086edbb7d69945e00ee7698fe6d3 ldcc-2.0.7.tgz 74060
+SHA256 eac7236a1e280ee16660ad68bf43e9775bb72d2d472e3f1efa467e9719e071ab ldcc-2.0.7.tgz 74060
diff --git a/net-p2p/ldcc/files/ldcc-2.0.7-tvision2.1.0.patch b/net-p2p/ldcc/files/ldcc-2.0.7-tvision2.1.0.patch
new file mode 100644
index 000000000000..665d5559e085
--- /dev/null
+++ b/net-p2p/ldcc/files/ldcc-2.0.7-tvision2.1.0.patch
@@ -0,0 +1,102 @@
+--- ldcc-2.0.7/src/d_error.cc
++++ ldcc-2.0.7/src/d_error.cc
+@@ -577,7 +577,7 @@
+ insert(new TLabel(TRect(29, 2, 39, 3), "~F~iletype:", V));
+
+ IL[4] = new TInputLine(TRect(50, 3, 72, 4), 21);
+- IL[4]->SetValidator(new TNumberValidator());
++ IL[4]->setValidator(new TNumberValidator());
+ insert(IL[4]);
+ insert(new TLabel(TRect(51, 2, 61, 3), "File si~z~e:", IL[4]));
+
+--- ldcc-2.0.7/src/options.cc
++++ ldcc-2.0.7/src/options.cc
+@@ -37,6 +37,7 @@
+ #define Uses_TDeskTop
+ #define Uses_TView
+ #define Uses_TValidator
++#define Uses_TRangeValidator
+ #include <tv.h>
+
+ #include "liczby.h"
+@@ -140,7 +141,7 @@
+ D->insert(new TLabel(TRect(2,3,19,4), "~U~ser info:", IL));
+
+ IL = new TInputLine(TRect(20,4,24,5), 2);
+- IL->SetValidator(new TNumberValidator());
++ IL->setValidator(new TNumberValidator());
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,4,19,5), "~F~ree slots:", IL));
+
+@@ -154,12 +155,12 @@
+
+ IL = new TInputLine(TRect(20,8,27,9), 6);
+ VL = new TRangeValidator(1L,65535L);
+- IL->SetValidator(VL);
++ IL->setValidator(VL);
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,8,19,9), "Ho~s~t Port:", IL));
+
+ IL = new TInputLine(TRect(20,9,31,10), 10);
+- IL->SetValidator(new TEmptyValidator());
++ IL->setValidator(new TEmptyValidator());
+ H = new THistory(TRect(32,9,35,10), IL, 1);
+ D->insert(H);
+ historyAdd(1, "56Kbps");
+@@ -175,13 +176,13 @@
+ D->insert(new TLabel(TRect(2,9,20,10), "Connection ~t~ype:", IL));
+
+ IL = new TInputLine(TRect(20,10,41,11), 20);
+- IL->SetValidator(new TNumberValidator());
++ IL->setValidator(new TNumberValidator());
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,10,19,11), "Offs~e~t:", IL));
+ D->insert(new TStaticText(TRect(42,10,50,11), "bytes"));
+
+ IL = new TInputLine(TRect(20,11,24,12), 3);
+- IL->SetValidator(new TNumberValidator());
++ IL->setValidator(new TNumberValidator());
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,11,20,12), "Connction ti~m~eout:", IL));
+ D->insert(new TStaticText(TRect(25,11,30,12), "sec."));
+@@ -198,13 +199,13 @@
+ D->insert(new TCheckBoxes(TRect(31,16,57,17), new TSItem("Log errors/debug",NULL)));
+
+ IL = new TInputLine(TRect(28,19,34,20), 5);
+- IL->SetValidator(new TNumberValidator());
++ IL->setValidator(new TNumberValidator());
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,19,27,20), "U~p~load bandwidth limit:", IL));
+ D->insert(new TStaticText(TRect(35,19,45,20), "x 0,5 kB/s"));
+
+ IL = new TInputLine(TRect(28,20,34,21), 5);
+- IL->SetValidator(new TNumberValidator());
++ IL->setValidator(new TNumberValidator());
+ D->insert(IL);
+ D->insert(new TLabel(TRect(2,20,27,21), "Do~w~nload bandwidth limit:", IL));
+ D->insert(new TStaticText(TRect(35,20,45,21), "x 1 kB/s"));
+@@ -333,20 +334,20 @@
+
+ for (c=0; c<10; c++) {
+ IL = new TInputLine(TRect(2,4+c,7,5+c), 4);
+- IL->SetValidator(new TRangeValidator(0L, 255L));
++ IL->setValidator(new TRangeValidator(0L, 255L));
+ D->insert(IL);
+ D->insert(new TStaticText(TRect(8,4+c,10,5+c), "->"));
+ IL = new TInputLine(TRect(11,4+c,16,5+c), 4);
+- IL->SetValidator(new TRangeValidator(0L, 255L));
++ IL->setValidator(new TRangeValidator(0L, 255L));
+ D->insert(IL);
+ }
+ for (c=0; c<10; c++) {
+ IL = new TInputLine(TRect(22,4+c,27,5+c), 4);
+- IL->SetValidator(new TRangeValidator(0L, 255L));
++ IL->setValidator(new TRangeValidator(0L, 255L));
+ D->insert(IL);
+ D->insert(new TStaticText(TRect(28,4+c,30,5+c), "->"));
+ IL = new TInputLine(TRect(31,4+c,36,5+c), 4);
+- IL->SetValidator(new TRangeValidator(0L, 255L));
++ IL->setValidator(new TRangeValidator(0L, 255L));
+ D->insert(IL);
+ }
+
diff --git a/net-p2p/ldcc/ldcc-2.0.7.ebuild b/net-p2p/ldcc/ldcc-2.0.7.ebuild
index a6ed84b696b9..06d5fcdfebb0 100644
--- a/net-p2p/ldcc/ldcc-2.0.7.ebuild
+++ b/net-p2p/ldcc/ldcc-2.0.7.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ldcc/ldcc-2.0.7.ebuild,v 1.9 2005/07/10 20:02:06 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ldcc/ldcc-2.0.7.ebuild,v 1.10 2007/01/24 10:08:18 armin76 Exp $
+
+inherit eutils
IUSE=""
@@ -15,6 +17,13 @@ KEYWORDS="x86 ~ppc ~amd64"
DEPEND="net-p2p/dctc
dev-libs/tvision"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-tvision2.1.0.patch"
+}
+
src_compile() {
econf \
--with-tv-include=/usr/include/rhtvision \