summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2003-03-13 11:57:55 +0000
committerTilman Klar <phoenix@gentoo.org>2003-03-13 11:57:55 +0000
commitf880a3a1e0583116b1cf0a37e6b5f9393d33ae92 (patch)
treeb88664f5b5294fa165101534eca3829eabd20921
parentVersion bump and bugfixes (bug #11465) (diff)
downloadgentoo-2-f880a3a1e0583116b1cf0a37e6b5f9393d33ae92.tar.gz
gentoo-2-f880a3a1e0583116b1cf0a37e6b5f9393d33ae92.tar.bz2
gentoo-2-f880a3a1e0583116b1cf0a37e6b5f9393d33ae92.zip
Incorporated latest bugfixes (bug #11465) into XWine-0.2.2.ebuild and killed a few of my typos in ChangeLog. :)
-rw-r--r--app-emulation/XWine/ChangeLog9
-rw-r--r--app-emulation/XWine/XWine-0.2.2.ebuild27
2 files changed, 25 insertions, 11 deletions
diff --git a/app-emulation/XWine/ChangeLog b/app-emulation/XWine/ChangeLog
index f3bb8b89880a..db7fe3d056f7 100644
--- a/app-emulation/XWine/ChangeLog
+++ b/app-emulation/XWine/ChangeLog
@@ -1,18 +1,21 @@
# ChangeLog for app-emulation/XWine
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.6 2003/03/13 11:52:37 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/ChangeLog,v 1.7 2003/03/13 11:57:55 phoenix Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
*XWine-0.3.ebuild (13 Mar 2002)
- 13 Mar 2002; phoen][x <phoenix@gentoo.org> XWine-0.3.ebuild :
- Verison bump. This ebuild fixes problems with the interactive configure
+ 13 Mar 2003; phoen][x <phoenix@gentoo.org> XWine-0.3.ebuild, files/digest-XWine-0.3 :
+ Version bump. This ebuild fixes problems with the interactive configure
and ends the gnome dependency trouble: XWine depends on gnome, there's no
way to compile it without gnome-libs being installed.
*XWine-0.2.2.ebuild (17 Aug 2002)
+ 13 Mar 2003; phoen][x <phoenix@gentoo.org> XWine-0.2.2.ebuild :
+ Incorporated latest bugfixes (bug #11465) into this ebuild.
+
03 Sep 2002; Nick Hadaway <raker@gentoo.org> XWine-0.2.2.ebuild :
Changed to econf and einstall. Added myconf switches for gnome and
nls support. Changed dependancy from libgnome to gnome-libs and
diff --git a/app-emulation/XWine/XWine-0.2.2.ebuild b/app-emulation/XWine/XWine-0.2.2.ebuild
index 2154003b9a32..335585c1d103 100644
--- a/app-emulation/XWine/XWine-0.2.2.ebuild
+++ b/app-emulation/XWine/XWine-0.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.6 2003/02/13 07:11:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.2.2.ebuild,v 1.7 2003/03/13 11:57:55 phoenix Exp $
DESCRIPTION="GTK frontend for Wine"
HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
@@ -15,8 +15,8 @@ DEPEND=">=x11-libs/gtk+-1.2.10-r8
>=net-www/mozilla-1.0-r2
>=app-emulation/wine-20020710-r1
sys-devel/bison
- gnome? ( >=gnome-base/gnome-libs-1.4.2
- >=gnome-base/ORBit-0.5.17 )
+ >=gnome-base/gnome-libs-1.4.2
+ >=gnome-base/ORBit-0.5.17
nls? ( sys-devel/gettext )"
RDEPEND="${DEPEND}
>=app-emulation/winesetuptk-0.6.0b-r2"
@@ -26,15 +26,26 @@ S="${WORKDIR}/${P}_en"
src_compile() {
local myconf
- use gnome && myconf="--with-gnome" \
- || myconf="--without-gnome"
-
use nls && myconf="${myconf} --enable-nls" \
|| myconf="${myconf} --disable-nls"
+ MOZ="`which mozilla`"
+
+ if [ -f ${MOZ} ] ; then
+ einfo "Setting up src/donnees.h to use mozilla as help browser."
+ cp -f ${S}/configure.d ${S}/configure
+ cp -f ${S}/src/donnees.h.in ${S}/src/donnees.h
+ echo "#define NAVIGATEUR \"${MOZ} -f\"" >> ${S}/src/donnees.h
+ else
+ ewarn "Mozilla not found in current PATH."
+ ewarn "PATH = ${PATH}"
+ die "Mozilla not found."
+ fi
+
+
econf ${myconf}
- make || die
+ emake || die
}
src_install() {
@@ -50,4 +61,4 @@ pkg_postinst() {
einfo "${PN} requires a setup Wine to start....It is recommended"
einfo "that you run winesetuptk prior to running ${PN} to setup"
einfo "a base Wine install"
-}
+}