summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 03:08:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 03:08:00 +0000
commitf6c074b973b053b65fa79b7f3240cf241b5c39d1 (patch)
treed56cd2e2d440c64c92c2469ff4e2ccada2d55ddc
parentarm KEYWORDS (diff)
downloadgentoo-2-f6c074b973b053b65fa79b7f3240cf241b5c39d1.tar.gz
gentoo-2-f6c074b973b053b65fa79b7f3240cf241b5c39d1.tar.bz2
gentoo-2-f6c074b973b053b65fa79b7f3240cf241b5c39d1.zip
arm KEYWORDS
-rw-r--r--net-fs/samba/samba-3.0.2a-r2.ebuild29
-rw-r--r--net-ftp/oftpd/oftpd-0.3.7-r1.ebuild15
-rw-r--r--net-libs/openslp/openslp-1.0.11.ebuild17
-rw-r--r--net-misc/oidentd/oidentd-2.0.7-r1.ebuild25
-rw-r--r--net-print/cups/cups-1.1.20-r1.ebuild7
5 files changed, 40 insertions, 53 deletions
diff --git a/net-fs/samba/samba-3.0.2a-r2.ebuild b/net-fs/samba/samba-3.0.2a-r2.ebuild
index 2cae2d8b3c74..3f8f77efa368 100644
--- a/net-fs/samba/samba-3.0.2a-r2.ebuild
+++ b/net-fs/samba/samba-3.0.2a-r2.ebuild
@@ -1,12 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.2a-r2.ebuild,v 1.9 2004/05/12 05:18:38 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-3.0.2a-r2.ebuild,v 1.10 2004/05/28 03:08:00 vapier Exp $
inherit eutils
-IUSE="kerberos mysql xml acl cups ldap pam readline python"
-IUSE="${IUSE} oav"
-
DESCRIPTION="SAMBA is a suite of SMB and CIFS client/server programs for UNIX"
HOMEPAGE="http://www.samba.org/
http://www.openantivirus.org/projects.php"
@@ -23,25 +20,27 @@ SRC_URI="mirror://samba/${PN}${_CVS}.tar.bz2
oav? mirror://sourceforge/openantivirus/${PN}-vscan-${VSCAN_VER}.tar.bz2
ldap? http://samba.idealx.org/dist/smbldap-tools-${SMBLDAP_TOOLS_VER}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ~ia64 s390"
+IUSE="kerberos mysql xml acl cups ldap pam readline python"
+IUSE="${IUSE} oav"
+
_COMMON_DEPS="dev-libs/popt
- readline? sys-libs/readline
- ldap? ( kerberos? ( app-crypt/mit-krb5 ) )
+ readline? ( sys-libs/readline )
+ !arm? ( ldap? ( kerberos? ( app-crypt/mit-krb5 ) ) )
mysql? ( dev-db/mysql sys-libs/zlib )
xml? ( dev-libs/libxml2 sys-libs/zlib )
- acl? sys-apps/acl
- cups? net-print/cups
- ldap? net-nds/openldap
- pam? sys-libs/pam
+ acl? ( sys-apps/acl )
+ cups? ( net-print/cups )
+ !arm? ( ldap? ( net-nds/openldap ) )
+ pam? ( sys-libs/pam )
python? dev-lang/python"
DEPEND="sys-devel/autoconf
>=sys-apps/sed-4
${_COMMON_DEPS}"
#IDEALX scripts are now using Net::LDAP
-RDEPEND="ldap? dev-perl/perl-ldap ${_COMMON_DEPS}"
-
-KEYWORDS="x86 ppc sparc mips hppa amd64 ~ia64 alpha s390"
-LICENSE="GPL-2"
-SLOT="0"
+RDEPEND="ldap? ( dev-perl/perl-ldap ) ${_COMMON_DEPS}"
src_unpack() {
local i
diff --git a/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild b/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild
index 9588ec18c864..7e643d3a2e2c 100644
--- a/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild
+++ b/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild,v 1.2 2004/04/28 17:55:56 eradicator Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/oftpd/oftpd-0.3.7-r1.ebuild,v 1.3 2004/05/28 03:04:03 vapier Exp $
DESCRIPTION="Secure, small, anonymous only ftpd"
-SRC_URI="http://www.time-travellers.org/oftpd/${P}.tar.gz"
HOMEPAGE="http://www.time-travellers.org/oftpd"
+SRC_URI="http://www.time-travellers.org/oftpd/${P}.tar.gz"
-DEPEND="virtual/glibc"
-
-SLOT="0"
LICENSE="as-is"
-KEYWORDS="x86 sparc ~ppc ~ppc64"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc arm ~ppc64"
+IUSE=""
+
+DEPEND="virtual/glibc"
src_compile() {
# local myconf
diff --git a/net-libs/openslp/openslp-1.0.11.ebuild b/net-libs/openslp/openslp-1.0.11.ebuild
index 3a9f1c6f48a7..da58e38a8a10 100644
--- a/net-libs/openslp/openslp-1.0.11.ebuild
+++ b/net-libs/openslp/openslp-1.0.11.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-1.0.11.ebuild,v 1.11 2004/05/12 01:35:53 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/openslp/openslp-1.0.11.ebuild,v 1.12 2004/05/28 03:06:17 vapier Exp $
inherit gnuconfig
-IUSE=""
-
DESCRIPTION="An open-source implementation of Service Location Protocol"
-HOMEPAGE="http://www.openslp.org"
+HOMEPAGE="http://www.openslp.org/"
SRC_URI="mirror://sourceforge/openslp/${P}.tar.gz"
-KEYWORDS="ia64 x86 sparc ppc hppa amd64 alpha mips s390"
-DEPEND="virtual/glibc"
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390"
+IUSE=""
+
+DEPEND="virtual/glibc"
src_unpack() {
unpack ${A}
-
# needed at least by alpha and amd64
gnuconfig_update
}
@@ -29,7 +28,7 @@ src_compile() {
src_install() {
einstall || die
- dodoc AUTHORS FAQ COPYING ChangeLog NEWS README* THANKS
+ dodoc AUTHORS FAQ ChangeLog NEWS README* THANKS
rm -rf ${D}/usr/doc
dohtml -r .
exeinto /etc/init.d
diff --git a/net-misc/oidentd/oidentd-2.0.7-r1.ebuild b/net-misc/oidentd/oidentd-2.0.7-r1.ebuild
index 78ae2104b2ca..82b74df949e8 100644
--- a/net-misc/oidentd/oidentd-2.0.7-r1.ebuild
+++ b/net-misc/oidentd/oidentd-2.0.7-r1.ebuild
@@ -1,42 +1,35 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.7-r1.ebuild,v 1.5 2003/12/15 07:23:10 avenj Exp $
-
-IUSE="ipv6"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.7-r1.ebuild,v 1.6 2004/05/28 03:03:20 vapier Exp $
DESCRIPTION="Another (RFC1413 compliant) ident daemon"
HOMEPAGE="http://dev.ojnk.net/"
SRC_URI="mirror://sourceforge/ojnk/${P}.tar.gz"
-KEYWORDS="x86 sparc alpha ia64 amd64"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 sparc alpha arm amd64 ia64"
+IUSE="ipv6"
DEPEND="virtual/glibc"
src_compile() {
- local myconf=""
-
- use ipv6 && \
- myconf="${myconf} --enable-ipv6" || \
- myconf="${myconf} --disable-ipv6"
-
-
./configure \
--prefix=/usr \
--mandir=/usr/share/man \
- ${myconf} || die
+ `use_enable ipv6` \
+ || die
emake || die
}
src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog README TODO NEWS \
- ${FILESDIR}/oidentd_masq.conf ${FILESDIR}/oidentd.conf
+ ${FILESDIR}/oidentd_masq.conf ${FILESDIR}/oidentd.conf
exeinto /etc/init.d ; newexe ${FILESDIR}/oidentd-${PV}-init oidentd
insinto /etc/conf.d ; newins ${FILESDIR}/oidentd-${PV}-confd oidentd
}
pkg_postinst() {
- einfo Example configuration files are in /usr/share/doc/${P}
+ einfo Example configuration files are in /usr/share/doc/${PF}
}
-
diff --git a/net-print/cups/cups-1.1.20-r1.ebuild b/net-print/cups/cups-1.1.20-r1.ebuild
index 23f37b0c0ef3..3beaeb4e595a 100644
--- a/net-print/cups/cups-1.1.20-r1.ebuild
+++ b/net-print/cups/cups-1.1.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.20-r1.ebuild,v 1.2 2004/05/12 04:46:15 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.20-r1.ebuild,v 1.3 2004/05/28 03:05:14 vapier Exp $
inherit eutils flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.easysw.com/pub/cups/${PV}/${P}-source.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc alpha hppa amd64 ia64 mips s390"
+KEYWORDS="x86 ~ppc sparc mips alpha arm hppa amd64 ia64 s390"
IUSE="ssl slp pam"
DEP="virtual/glibc
@@ -20,13 +20,10 @@ DEP="virtual/glibc
>=media-libs/libpng-1.2.1
>=media-libs/tiff-3.5.5
>=media-libs/jpeg-6b"
-
DEPEND="${DEP}
>=sys-devel/autoconf-2.58"
-
RDEPEND="${DEP}
!virtual/lpr"
-
PROVIDE="virtual/lpr"
src_unpack() {