summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2001-11-04 00:34:11 +0000
committerBart Verwilst <verwilst@gentoo.org>2001-11-04 00:34:11 +0000
commitf5cbc951032ba8a90edffd5b80d51248335a5991 (patch)
treedf7611599bcbb7471109fe758cc46fd56cbae676
parentRemoved from incoming.. Version 1.00 in net-im. (diff)
downloadgentoo-2-f5cbc951032ba8a90edffd5b80d51248335a5991.tar.gz
gentoo-2-f5cbc951032ba8a90edffd5b80d51248335a5991.tar.bz2
gentoo-2-f5cbc951032ba8a90edffd5b80d51248335a5991.zip
Added to incoming
-rw-r--r--incoming/gsl-1.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/incoming/gsl-1.0.ebuild b/incoming/gsl-1.0.ebuild
new file mode 100644
index 000000000000..fd13084e5989
--- /dev/null
+++ b/incoming/gsl-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.7 2001/08/25 21:15:08 chadh Exp
+
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The GNU Scientific Library"
+
+SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
+
+HOMEPAGE="http://sources.redhat.com/gsl/"
+
+DEPEND="virtual/glibc"
+
+#RDEPEND=""
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+ local myconf
+ myconf="--disable-libtool-lock"
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+#Uncomment the 'make check ...' line if you want to run the test suite.
+#Note that the check.log file will be several megabytes in size.
+# make check > check.log 2>&1 || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES NEWS
+
+}
+