summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-17 19:14:18 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-17 19:14:18 +0000
commitf3eef615b211a634587de971f7ee3e93f1b5e1b6 (patch)
tree3b2616bfb822bd07ef6c8c7f17193e94404f55ea
parentalpha/sparc stable wrt #299212 (diff)
downloadgentoo-2-f3eef615b211a634587de971f7ee3e93f1b5e1b6.tar.gz
gentoo-2-f3eef615b211a634587de971f7ee3e93f1b5e1b6.tar.bz2
gentoo-2-f3eef615b211a634587de971f7ee3e93f1b5e1b6.zip
Commit slotted libjpeg.so.7 (binary only) ebuild (used by icedtea6-bin) wrt #300782, thanks to Mike Frysinger.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
-rw-r--r--media-libs/jpeg/ChangeLog8
-rw-r--r--media-libs/jpeg/jpeg-7-r1.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 06f08d473624..654a51ba2ad5 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/jpeg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.89 2010/01/15 09:43:26 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.90 2010/01/17 19:14:18 ssuominen Exp $
+
+*jpeg-7-r1 (17 Jan 2010)
+
+ 17 Jan 2010; Samuli Suominen <ssuominen@gentoo.org> +jpeg-7-r1.ebuild:
+ Commit slotted libjpeg.so.7 (binary only) ebuild (used by icedtea6-bin)
+ wrt #300782, thanks to Mike Frysinger.
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org> jpeg-7.ebuild:
add some more KEYWORDS for Prefix
diff --git a/media-libs/jpeg/jpeg-7-r1.ebuild b/media-libs/jpeg/jpeg-7-r1.ebuild
new file mode 100644
index 000000000000..97e1675310c7
--- /dev/null
+++ b/media-libs/jpeg/jpeg-7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-7-r1.ebuild,v 1.1 2010/01/17 19:14:18 ssuominen Exp $
+
+# this ebuild is only for the libjpeg.so.7 SONAME for ABI compat
+
+EAPI="2"
+
+inherit eutils libtool multilib
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ mirror://gentoo/${PN}-6b-patches-2.tar.bz2"
+
+LICENSE="as-is"
+SLOT="7"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ epatch "${WORKDIR}"/patch/60_all_jpeg-maxmem-sysconf.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-shared \
+ --disable-static \
+ --enable-maxmem=64
+}
+
+src_compile() {
+ emake libjpeg.la || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)
+ doexe .libs/libjpeg.so.7 || die
+}