summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-05-21 14:19:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-05-21 14:19:30 +0000
commitf368813d5d20cab4935d8565556baa5894ae4d1c (patch)
tree725e3cd228e69d541ed16bf9e2f161d0a64a967d
parentRESTRICT=test for version 20080929, #278430, broken by upstream (diff)
downloadgentoo-2-f368813d5d20cab4935d8565556baa5894ae4d1c.tar.gz
gentoo-2-f368813d5d20cab4935d8565556baa5894ae4d1c.tar.bz2
gentoo-2-f368813d5d20cab4935d8565556baa5894ae4d1c.zip
Revision bump to force rebuild with modified call to sed wrt #320837 by Cédric Jeanneret.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--media-libs/gd/ChangeLog9
-rw-r--r--media-libs/gd/gd-2.0.35-r1.ebuild8
-rw-r--r--media-libs/gd/gd-2.0.35-r2.ebuild55
3 files changed, 64 insertions, 8 deletions
diff --git a/media-libs/gd/ChangeLog b/media-libs/gd/ChangeLog
index 8d04f7fdebbc..35856245d4b6 100644
--- a/media-libs/gd/ChangeLog
+++ b/media-libs/gd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/gd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.63 2010/05/20 17:32:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/ChangeLog,v 1.64 2010/05/21 14:19:30 ssuominen Exp $
+
+*gd-2.0.35-r2 (21 May 2010)
+
+ 21 May 2010; Samuli Suominen <ssuominen@gentoo.org> gd-2.0.35-r1.ebuild,
+ +gd-2.0.35-r2.ebuild:
+ Revision bump to force rebuild with modified call to sed wrt #320837 by
+ Cédric Jeanneret.
20 May 2010; Samuli Suominen <ssuominen@gentoo.org> gd-2.0.35-r1.ebuild:
Try libpng14-config and -lpng14 before falling back to libpng-config and
diff --git a/media-libs/gd/gd-2.0.35-r1.ebuild b/media-libs/gd/gd-2.0.35-r1.ebuild
index 190f3ccb1a41..b028f1371eb8 100644
--- a/media-libs/gd/gd-2.0.35-r1.ebuild
+++ b/media-libs/gd/gd-2.0.35-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r1.ebuild,v 1.11 2010/05/21 10:34:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r1.ebuild,v 1.12 2010/05/21 14:19:30 ssuominen Exp $
EAPI=1
inherit autotools
@@ -28,12 +28,6 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-libpng14.patch \
"${FILESDIR}"/${P}-maxcolors.patch
- # Try libpng14 first, then fallback to plain libpng
- sed -i \
- -e 's/libpng12-config/libpng14-config/g' \
- -e 's/-lpng12/-lpng14/' \
- configure.ac || die
-
eautoconf
find . -type f -print0 | xargs -0 touch -r configure
}
diff --git a/media-libs/gd/gd-2.0.35-r2.ebuild b/media-libs/gd/gd-2.0.35-r2.ebuild
new file mode 100644
index 000000000000..c30ba582e9f3
--- /dev/null
+++ b/media-libs/gd/gd-2.0.35-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gd/gd-2.0.35-r2.ebuild,v 1.1 2010/05/21 14:19:30 ssuominen Exp $
+
+EAPI=1
+inherit autotools
+
+DESCRIPTION="A graphics library for fast image creation"
+HOMEPAGE="http://libgd.org/"
+SRC_URI="http://libgd.org/releases/${P}.tar.bz2"
+
+LICENSE="|| ( as-is BSD )"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="fontconfig jpeg png truetype xpm"
+
+RDEPEND="fontconfig? ( media-libs/fontconfig )
+ jpeg? ( >=media-libs/jpeg-6b:0 )
+ png? ( >=media-libs/libpng-1.2.43-r2:0
+ sys-libs/zlib )
+ truetype? ( >=media-libs/freetype-2.1.5 )
+ xpm? ( x11-libs/libXpm x11-libs/libXt )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-libpng14.patch \
+ "${FILESDIR}"/${P}-maxcolors.patch
+
+ # Try libpng14 first, then fallback to plain libpng
+ sed -i \
+ -e 's:png12:png14:' \
+ configure.ac || die
+
+ eautoconf
+ find . -type f -print0 | xargs -0 touch -r configure
+}
+
+src_compile() {
+ econf \
+ $(use_with fontconfig) \
+ $(use_with png) \
+ $(use_with truetype freetype) \
+ $(use_with jpeg) \
+ $(use_with xpm) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc INSTALL README*
+ dohtml -r ./
+}