summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-03 10:06:56 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-03 10:06:56 +0000
commitf333f7dcd514ab6f13f24cbee0a5deca7e0d56e2 (patch)
tree2bc6ddd45017c775650e866d56ba9e319d1c5a87
parentUse virtual/udev instead of sys-fs/udev wrt #444398 (diff)
downloadgentoo-2-f333f7dcd514ab6f13f24cbee0a5deca7e0d56e2.tar.gz
gentoo-2-f333f7dcd514ab6f13f24cbee0a5deca7e0d56e2.tar.bz2
gentoo-2-f333f7dcd514ab6f13f24cbee0a5deca7e0d56e2.zip
dev-cpp/pstreams: Version Bump
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
-rw-r--r--dev-cpp/pstreams/ChangeLog10
-rw-r--r--dev-cpp/pstreams/metadata.xml8
-rw-r--r--dev-cpp/pstreams/pstreams-0.48.ebuild41
3 files changed, 53 insertions, 6 deletions
diff --git a/dev-cpp/pstreams/ChangeLog b/dev-cpp/pstreams/ChangeLog
index c49a1cc70aab..15593dbf5688 100644
--- a/dev-cpp/pstreams/ChangeLog
+++ b/dev-cpp/pstreams/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/pstreams
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.1 2010/05/18 20:31:41 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/ChangeLog,v 1.2 2012/12/03 10:06:56 jlec Exp $
+
+*pstreams-0.48 (03 Dec 2012)
+
+ 03 Dec 2012; Justin Lecher <jlec@gentoo.org> +pstreams-0.48.ebuild,
+ metadata.xml:
+ Version Bump
*pstreams-0.7.0 (18 May 2010)
diff --git a/dev-cpp/pstreams/metadata.xml b/dev-cpp/pstreams/metadata.xml
index 4fba309d97ba..c1661663322e 100644
--- a/dev-cpp/pstreams/metadata.xml
+++ b/dev-cpp/pstreams/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>jlec@gentoo.org</email>
- <name>Justin Lecher</name>
-</maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-cpp/pstreams/pstreams-0.48.ebuild b/dev-cpp/pstreams/pstreams-0.48.ebuild
new file mode 100644
index 000000000000..008164c1320e
--- /dev/null
+++ b/dev-cpp/pstreams/pstreams-0.48.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/pstreams/pstreams-0.48.ebuild,v 1.1 2012/12/03 10:06:56 jlec Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="C++ wrapper for the POSIX.2 functions popen(3) and pclose(3)"
+HOMEPAGE="http://pstreams.sourceforge.net/"
+SRC_URI="
+ mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( mirror://sourceforge/${PN}/${P}-docs.tar.gz )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-3"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+ use doc && emake
+}
+
+src_test() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ check
+}
+
+src_install() {
+ insinto /usr/include
+ doins pstream.h
+
+ dodoc AUTHORS ChangeLog README
+
+ use doc && dohtml -r "${WORKDIR}"/${PN}-docs-${PV}/* -R
+}