summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-09 17:51:33 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-09 17:51:33 +0000
commitf248e91a20fc5f1ba0722cf0f56dff6c96c437ae (patch)
treeec651e2e8765f5cbf3caa455264f4e6a660a242e
parentStable for x86, wrt bug #425334 (diff)
downloadgentoo-2-f248e91a20fc5f1ba0722cf0f56dff6c96c437ae.tar.gz
gentoo-2-f248e91a20fc5f1ba0722cf0f56dff6c96c437ae.tar.bz2
gentoo-2-f248e91a20fc5f1ba0722cf0f56dff6c96c437ae.zip
keyword amd64-linux, x86-linux, and adapted changes from the science overlay for macos prefix, thanks Francois Bissey
(Portage version: 2.2.01.20757-prefix/cvs/Linux x86_64)
-rw-r--r--sci-libs/dsdp/ChangeLog8
-rw-r--r--sci-libs/dsdp/dsdp-5.8-r2.ebuild15
-rw-r--r--sci-libs/dsdp/files/dsdp-5.8-malloc.patch10
3 files changed, 26 insertions, 7 deletions
diff --git a/sci-libs/dsdp/ChangeLog b/sci-libs/dsdp/ChangeLog
index 3363fa513396..82b767c052ec 100644
--- a/sci-libs/dsdp/ChangeLog
+++ b/sci-libs/dsdp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/dsdp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/ChangeLog,v 1.7 2012/05/04 08:22:53 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/ChangeLog,v 1.8 2012/07/09 17:51:33 bicatali Exp $
+
+ 09 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/dsdp-5.8-malloc.patch, dsdp-5.8-r2.ebuild:
+ keyword amd64-linux, x86-linux, and adapted changes from the science overlay
+ for macos prefix, thanks Francois Bissey
04 May 2012; Jeff Horelick <jdhore@gentoo.org> dsdp-5.8-r2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -33,4 +38,3 @@
07 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> +dsdp-5.8.ebuild,
+metadata.xml:
Initial import
-
diff --git a/sci-libs/dsdp/dsdp-5.8-r2.ebuild b/sci-libs/dsdp/dsdp-5.8-r2.ebuild
index 5c8a550e5091..50d1177f5323 100644
--- a/sci-libs/dsdp/dsdp-5.8-r2.ebuild
+++ b/sci-libs/dsdp/dsdp-5.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/dsdp-5.8-r2.ebuild,v 1.2 2012/05/04 08:22:53 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/dsdp-5.8-r2.ebuild,v 1.3 2012/07/09 17:51:33 bicatali Exp $
EAPI=4
@@ -14,7 +14,7 @@ SRC_URI="http://www.mcs.anl.gov/hs/software/DSDP//${MYP}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos ~x86-linux ~x86-macos ~x64-macos"
IUSE="doc examples"
RDEPEND="virtual/lapack"
@@ -24,18 +24,21 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYP}"
make_shared_lib() {
- local soname=$(basename "${1%.a}").so.$(get_major_version)
+ local soname=$(basename "${1%.a}")$(get_libname $(get_major_version))
einfo "Making ${soname}"
${2:-$(tc-getCC)} ${LDFLAGS} \
-shared -Wl,-soname="${soname}" \
+ $([[ ${CHOST} == *-darwin* ]] && echo "-Wl,-install_name -Wl,${EPREFIX}/usr/$(get_libdir)/${soname}") \
-Wl,--whole-archive "${1}" -Wl,--no-whole-archive \
-o $(dirname "${1}")/"${soname}" \
-lm $(pkg-config --libs blas lapack) || return 1
+
}
src_prepare() {
epatch \
"${FILESDIR}"/${P}-readsdpa.patch \
+ "${FILESDIR}"/${P}-malloc.patch \
"${FILESDIR}"/${P}-gold.patch
# to do proper parallel compilation
find . -name Makefile -exec \
@@ -61,8 +64,10 @@ src_test() {
}
src_install() {
- dolib.so lib/lib${PN}.so.$(get_major_version)
- dosym lib${PN}.so.$(get_major_version) /usr/$(get_libdir)/lib${PN}.so
+ dolib.so lib/lib${PN}$(get_libname $(get_major_version))
+ dosym lib${PN}$(get_libname $(get_major_version)) \
+ /usr/$(get_libdir)/lib${PN}$(get_libname)
+
insinto /usr/include
doins include/*.h src/sdp/*.h
diff --git a/sci-libs/dsdp/files/dsdp-5.8-malloc.patch b/sci-libs/dsdp/files/dsdp-5.8-malloc.patch
new file mode 100644
index 000000000000..48e067d1d898
--- /dev/null
+++ b/sci-libs/dsdp/files/dsdp-5.8-malloc.patch
@@ -0,0 +1,10 @@
+--- src/sys/dsdploginfo.c.orig 2012-04-04 09:59:25.212518434 +1200
++++ src/sys/dsdploginfo.c 2012-04-04 10:00:05.676522161 +1200
+@@ -6,7 +6,6 @@
+ #include <stdarg.h>
+ #include <sys/types.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include "dsdpsys.h"
+ #include "dsdpbasictypes.h"
+