summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-03-24 22:08:02 +0000
committerRémi Cardona <remi@gentoo.org>2008-03-24 22:08:02 +0000
commitf227ed03baf08431954e3693e3f6558f417641b0 (patch)
treefc352164c659a58313967293e6fb0cfe782b95c7
parentRemoving per last rites - till unmigrated, untouched since 2005, nothing depe... (diff)
downloadgentoo-2-f227ed03baf08431954e3693e3f6558f417641b0.tar.gz
gentoo-2-f227ed03baf08431954e3693e3f6558f417641b0.tar.bz2
gentoo-2-f227ed03baf08431954e3693e3f6558f417641b0.zip
dev-cpp/cairomm: Bump to 1.5.0 with build fix for cairo 1.5.14
(Portage version: 2.1.4.4)
-rw-r--r--dev-cpp/cairomm/ChangeLog10
-rw-r--r--dev-cpp/cairomm/cairomm-1.5.0.ebuild44
-rw-r--r--dev-cpp/cairomm/files/cairomm-1.5.0-fix-new-cairo-API.patch40
3 files changed, 92 insertions, 2 deletions
diff --git a/dev-cpp/cairomm/ChangeLog b/dev-cpp/cairomm/ChangeLog
index 0abfa1bb1f04..194d43abc491 100644
--- a/dev-cpp/cairomm/ChangeLog
+++ b/dev-cpp/cairomm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/cairomm
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.23 2007/11/24 15:03:15 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.24 2008/03/24 22:08:02 remi Exp $
+
+*cairomm-1.5.0 (24 Mar 2008)
+
+ 24 Mar 2008; Rémi Cardona <remi@gentoo.org>
+ +files/cairomm-1.5.0-fix-new-cairo-API.patch, +cairomm-1.5.0.ebuild:
+ Bump to 1.5.0 with build fix for cairo 1.5.14
24 Nov 2007; Jeroen Roovers <jer@gentoo.org> cairomm-1.4.4.ebuild:
Stable for HPPA (bug #198845).
diff --git a/dev-cpp/cairomm/cairomm-1.5.0.ebuild b/dev-cpp/cairomm/cairomm-1.5.0.ebuild
new file mode 100644
index 000000000000..d88bed669987
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.5.0.ebuild,v 1.1 2008/03/24 22:08:02 remi Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=x11-libs/cairo-1.5.14"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # backport from git HEAD to fix build issue with cairo 1.5.14
+ epatch "${FILESDIR}/${PN}-1.5.0-fix-new-cairo-API.patch" || die "patch failed"
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable doc docs) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use examples; then
+ dodoc examples
+ fi
+}
diff --git a/dev-cpp/cairomm/files/cairomm-1.5.0-fix-new-cairo-API.patch b/dev-cpp/cairomm/files/cairomm-1.5.0-fix-new-cairo-API.patch
new file mode 100644
index 000000000000..45467cd233c9
--- /dev/null
+++ b/dev-cpp/cairomm/files/cairomm-1.5.0-fix-new-cairo-API.patch
@@ -0,0 +1,40 @@
+From: Murray Cumming <murrayc@murrayc.com>
+Date: Sun, 23 Mar 2008 10:19:54 +0000 (+0100)
+Subject: 2008-03-23 Murray Cumming <murrayc@murrayc.com>
+X-Git-Url: http://gitweb.cairographics.org/?p=cairomm.git;a=commitdiff;h=56d68c7dda87aaf7da08a64e8640222654b6ab22
+
+2008-03-23 Murray Cumming <murrayc@murrayc.com>
+
+ * cairomm/enums.h (FONT_TYPE_ATSUI, FONT_TYPE_QUARTZ):
+ Change the definition of FONT_TYPE_ATSUI from CAIRO_FONT_TYPE_ATSUI to
+ CAIRO_FONT_TYPE_QUARTZ (the same numerical value) and document it as
+ deprecated. The others should be documented too.
+ Added FONT_TYPE_QUARTZ.
+---
+
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,11 @@
++2008-03-23 Murray Cumming <murrayc@murrayc.com>
++
++ * cairomm/enums.h (FONT_TYPE_ATSUI, FONT_TYPE_QUARTZ):
++ Change the definition of FONT_TYPE_ATSUI from CAIRO_FONT_TYPE_ATSUI to
++ CAIRO_FONT_TYPE_QUARTZ (the same numerical value) and document it as
++ deprecated. The others should be documented too.
++ Added FONT_TYPE_QUARTZ.
++
+ == 1.5.0 ==
+
+ 2008-03-10 Jonathon Jongsma <jjongsma@gnome.org>
+--- a/cairomm/enums.h
++++ b/cairomm/enums.h
+@@ -192,7 +192,8 @@ typedef enum
+ FONT_TYPE_TOY = CAIRO_FONT_TYPE_TOY,
+ FONT_TYPE_FT = CAIRO_FONT_TYPE_FT,
+ FONT_TYPE_WIN32 = CAIRO_FONT_TYPE_WIN32,
+- FONT_TYPE_ATSUI = CAIRO_FONT_TYPE_ATSUI
++ FONT_TYPE_ATSUI = CAIRO_FONT_TYPE_QUARTZ, /**< @deprecated Use FONT_TYPE_QUARTZ instead. */
++ FONT_TYPE_QUARTZ = CAIRO_FONT_TYPE_QUARTZ
+ } FontType;
+
+ } // namespace Cairo