summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-13 14:33:38 +0000
committerTom William Payne <twp@gentoo.org>2003-05-13 14:33:38 +0000
commitf1d1e517f4163598042fbce1e143b5318eab84ba (patch)
tree84980bb710fb77edaa9c75eaad49e53eef92aded
parentInitial release (diff)
downloadgentoo-2-f1d1e517f4163598042fbce1e143b5318eab84ba.tar.gz
gentoo-2-f1d1e517f4163598042fbce1e143b5318eab84ba.tar.bz2
gentoo-2-f1d1e517f4163598042fbce1e143b5318eab84ba.zip
Initial release
-rw-r--r--dev-ruby/ruby-tcpwrap/ChangeLog8
-rw-r--r--dev-ruby/ruby-tcpwrap/Manifest4
-rw-r--r--dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.51
-rw-r--r--dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild26
-rw-r--r--net-libs/libident/ChangeLog8
-rw-r--r--net-libs/libident/Manifest4
-rw-r--r--net-libs/libident/files/digest-libident-0.221
-rw-r--r--net-libs/libident/libident-0.22.ebuild23
8 files changed, 71 insertions, 4 deletions
diff --git a/dev-ruby/ruby-tcpwrap/ChangeLog b/dev-ruby/ruby-tcpwrap/ChangeLog
new file mode 100644
index 000000000000..ed56e7aba17c
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-ruby/ruby-tcpwrap
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ChangeLog,v 1.1 2003/05/13 14:33:19 twp Exp $
+
+*ruby-tcpwrap-0.5 (13 May 2003)
+
+ 13 May 2003; Tom Payne <twp@gentoo.org> ruby-tcpwrap-0.5.ebuild :
+ Initial import. Ebuild submitted by Matsuu Takuto. Bug # 20896.
diff --git a/dev-ruby/ruby-tcpwrap/Manifest b/dev-ruby/ruby-tcpwrap/Manifest
index 8ed1b310c75f..dd1abbcc36d6 100644
--- a/dev-ruby/ruby-tcpwrap/Manifest
+++ b/dev-ruby/ruby-tcpwrap/Manifest
@@ -1,3 +1,3 @@
-MD5 84c62bc80045fc743759a6d055025fb9 ruby-tcpwrap-0.5.ebuild 552
-MD5 d605c04067ccc218739d536f8d0e11d1 .ruby-tcpwrap-0.5.ebuild.swp 16384
+MD5 6907db9260bce3e4dc8c4aab35ed026e ruby-tcpwrap-0.5.ebuild 708
+MD5 99e45a654d9a09c3c42947c760868dcb ChangeLog 388
MD5 a82c7f3f05166f1f662746bf4882646f files/digest-ruby-tcpwrap-0.5 66
diff --git a/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5 b/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5
new file mode 100644
index 000000000000..4d338ca03213
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/files/digest-ruby-tcpwrap-0.5
@@ -0,0 +1 @@
+MD5 fc0380da56a76d20038a9492be34cfba ruby-tcpwrap-0.5.tar.gz 4219
diff --git a/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild
new file mode 100644
index 000000000000..44f991e7d8d5
--- /dev/null
+++ b/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-tcpwrap/ruby-tcpwrap-0.5.ebuild,v 1.1 2003/05/13 14:33:19 twp Exp $
+
+DESCRIPTION="A TCP wrappers library for Ruby"
+HOMEPAGE="http://raa.ruby-lang.org/list.rhtml?name=ruby-tcpwrap"
+SRC_URI="http://shugo.net/archive/ruby-tcpwrap/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+DEPEND="dev-lang/ruby
+ net-libs/libident
+ sys-apps/tcp-wrappers"
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ ruby extconf.rb || die
+ emake || die
+}
+
+src_install() {
+ einstall
+ dodoc README*
+ insinto /usr/share/doc/${PF}/html
+ doins doc/*
+}
diff --git a/net-libs/libident/ChangeLog b/net-libs/libident/ChangeLog
new file mode 100644
index 000000000000..0aeca17e7f91
--- /dev/null
+++ b/net-libs/libident/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-libs/libident
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libident/ChangeLog,v 1.1 2003/05/13 14:30:17 twp Exp $
+
+*libident-0.22 (13 May 2003)
+
+ 13 May 2003; Tom Payne <twp@gentoo.org> libident-0.22.ebuild :
+ Initial release. Ebuild submitted by Matsuu Takuto. Bug # 20894.
diff --git a/net-libs/libident/Manifest b/net-libs/libident/Manifest
index eff8d132dd20..a42526f340ae 100644
--- a/net-libs/libident/Manifest
+++ b/net-libs/libident/Manifest
@@ -1,3 +1,3 @@
-MD5 8dbc8e888deedbc6b5ba82fbe967d233 libident-0.22.ebuild 575
-MD5 19b730540fc2473bb89b04e8111a2f39 .libident-0.22.ebuild.swp 12288
+MD5 a00d0598e098ed72640715c20659705d libident-0.22.ebuild 695
+MD5 3373fba9e87da03631eac49a516ccb2c ChangeLog 375
MD5 5a23249eaedb219866d8a766a145994c files/digest-libident-0.22 64
diff --git a/net-libs/libident/files/digest-libident-0.22 b/net-libs/libident/files/digest-libident-0.22
new file mode 100644
index 000000000000..2ed9f6a8cc44
--- /dev/null
+++ b/net-libs/libident/files/digest-libident-0.22
@@ -0,0 +1 @@
+MD5 218b6706e574ca5b41a0a675cf1860eb libident-0.22.tar.gz 10716
diff --git a/net-libs/libident/libident-0.22.ebuild b/net-libs/libident/libident-0.22.ebuild
new file mode 100644
index 000000000000..5fabf1047431
--- /dev/null
+++ b/net-libs/libident/libident-0.22.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libident/libident-0.22.ebuild,v 1.1 2003/05/13 14:30:17 twp Exp $
+
+DESCRIPTION="A small library to interface to the Ident protocol server"
+HOMEPAGE="ftp://ftp.lysator.liu.se/pub/ident/libs"
+SRC_URI="ftp://ftp.lysator.liu.se/pub/ident/libs/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~x86"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -DHAVE_ANSIHEADERS" all || die
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/include
+ doins ident.h
+ dolib.a libident.a
+ doman ident.3
+}