summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-06 10:53:07 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-06 10:53:07 +0000
commitedd1523bd08707566975d55e3662612bbc16d759 (patch)
tree7106e278aeb8c72a7f7ad6ff98065961b1f56942
parentA new revision, includes the bootsplash_resize script. (Manifest recommit) (diff)
downloadgentoo-2-edd1523bd08707566975d55e3662612bbc16d759.tar.gz
gentoo-2-edd1523bd08707566975d55e3662612bbc16d759.tar.bz2
gentoo-2-edd1523bd08707566975d55e3662612bbc16d759.zip
Initial import. Thanks to Julien TIERNY <julien.tierny@wanadoo.fr> (bug #42247).
-rw-r--r--dev-util/usb-robot/ChangeLog10
-rw-r--r--dev-util/usb-robot/Manifest2
-rw-r--r--dev-util/usb-robot/files/digest-usb-robot-0.2.01
-rw-r--r--dev-util/usb-robot/usb-robot-0.2.0.ebuild29
4 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/usb-robot/ChangeLog b/dev-util/usb-robot/ChangeLog
new file mode 100644
index 000000000000..8c416b1d6853
--- /dev/null
+++ b/dev-util/usb-robot/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/usb-robot
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/usb-robot/ChangeLog,v 1.1 2004/03/06 10:53:07 pyrania Exp $
+
+*usb-robot-0.2.0 (06 Mar 2004)
+
+ 06 Mar 2004; Markus Nigbur <pyrania@gentoo.org> usb-robot-0.2.0.ebuild:
+ Initial import. Thanks to Julien TIERNY <julien.tierny@wanadoo.fr> (bug
+ #42247).
+
diff --git a/dev-util/usb-robot/Manifest b/dev-util/usb-robot/Manifest
new file mode 100644
index 000000000000..d8068dc77f62
--- /dev/null
+++ b/dev-util/usb-robot/Manifest
@@ -0,0 +1,2 @@
+MD5 3f52f28613dd78a439d410627bc32694 usb-robot-0.2.0.ebuild 579
+MD5 453ff04426547c53e0ec1200e6029a02 files/digest-usb-robot-0.2.0 66
diff --git a/dev-util/usb-robot/files/digest-usb-robot-0.2.0 b/dev-util/usb-robot/files/digest-usb-robot-0.2.0
new file mode 100644
index 000000000000..248a1599b3f5
--- /dev/null
+++ b/dev-util/usb-robot/files/digest-usb-robot-0.2.0
@@ -0,0 +1 @@
+MD5 0a28be502afb3356d933203538d3d5bb usb-robot-0.2.0.tar.gz 43682
diff --git a/dev-util/usb-robot/usb-robot-0.2.0.ebuild b/dev-util/usb-robot/usb-robot-0.2.0.ebuild
new file mode 100644
index 000000000000..d472fecd16da
--- /dev/null
+++ b/dev-util/usb-robot/usb-robot-0.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/usb-robot/usb-robot-0.2.0.ebuild,v 1.1 2004/03/06 10:53:07 pyrania Exp $
+
+IUSE="usb perl readline"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="USB Reverse engineering tools"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://usb-robot.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="dev-libs/libusb"
+
+src_compile() {
+ econf \
+ --enable-smtp \
+ `use_enable perl` \
+ `use_enable readline` || die
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS NEWS README TODO COPYING ChangeLog
+}