summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-08 10:30:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-08 10:30:20 +0000
commited4d3529459e89afb6569b2118985b2a255045ee (patch)
treed49bfb1aa2f4ef544872d7bcd54c9248f9dd4f3e
parentgenerate shared lib with a SONAME (diff)
downloadgentoo-2-ed4d3529459e89afb6569b2118985b2a255045ee.tar.gz
gentoo-2-ed4d3529459e89afb6569b2118985b2a255045ee.tar.bz2
gentoo-2-ed4d3529459e89afb6569b2118985b2a255045ee.zip
Version bump #135594 by Ron Hu.
(Portage version: 2.1_rc4-r3)
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/files/digest-pciutils-2.2.36
-rw-r--r--sys-apps/pciutils/pciutils-2.2.3.ebuild64
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 073139f260c7..1d82eba63fda 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.73 2006/04/18 17:05:48 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.74 2006/06/08 10:30:19 vapier Exp $
+
+*pciutils-2.2.3 (08 Jun 2006)
+
+ 08 Jun 2006; Mike Frysinger <vapier@gentoo.org> +pciutils-2.2.3.ebuild:
+ Version bump #135594 by Ron Hu.
18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
pciutils-2.2.0-r1.ebuild:
diff --git a/sys-apps/pciutils/files/digest-pciutils-2.2.3 b/sys-apps/pciutils/files/digest-pciutils-2.2.3
new file mode 100644
index 000000000000..5190675617ab
--- /dev/null
+++ b/sys-apps/pciutils/files/digest-pciutils-2.2.3
@@ -0,0 +1,6 @@
+MD5 3b14976e7077587eec23c2d71cc5b022 pci.ids-20060608.bz2 108285
+RMD160 0768e2232a6003711de498ef8e7df805d4c880c7 pci.ids-20060608.bz2 108285
+SHA256 81418596523d437b260573d727d77130e91890f84265b58907f1175fa81224ed pci.ids-20060608.bz2 108285
+MD5 39747279aad46e7a6a3e1ea636d055b4 pciutils-2.2.3.tar.gz 1121334
+RMD160 429b3b21f4cb079c2f3620a4c4d14c6dc610a098 pciutils-2.2.3.tar.gz 1121334
+SHA256 e501df7734738d0625a3765498e1c4625a2fbaf408c86599eca2070c57bc4d4b pciutils-2.2.3.tar.gz 1121334
diff --git a/sys-apps/pciutils/pciutils-2.2.3.ebuild b/sys-apps/pciutils/pciutils-2.2.3.ebuild
new file mode 100644
index 000000000000..188c58d604be
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.3.ebuild,v 1.1 2006/06/08 10:30:20 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+STAMP=20060608
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz
+ mirror://gentoo/pci.ids-${STAMP}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.0.patch
+ epatch "${FILESDIR}"/${PN}-2.2.0-shared-lib.patch
+ epatch "${FILESDIR}"/${PN}-2.1.11-malloc.patch
+
+ # Set Gentoo paths
+ # and do not strip (breaks cross-compile), portage handles stripping
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e '/^IDSDIR=/s:=.*:=$(PREFIX)/share/misc:' \
+ -e '/INSTALL.* -s lspci /s: -s lspci : lspci :' \
+ Makefile || die
+
+ # Make sure we respect $AR / $RANLIB
+ sed -i \
+ -e '/ar rcs/s:ar:$(AR):' \
+ -e 's:ranlib:$(RANLIB):' \
+ lib/Makefile \
+ || die "sed lib/Makefile failed"
+
+ sed -i 's:wget -O:wget --connect-timeout=60 -O:' update-pciids.sh
+ ebegin "Updating pci.ids from the web"
+ if ! ./update-pciids.sh &> /dev/null ; then
+ # if we cant update, use a cached version
+ mv "${WORKDIR}"/pci.ids-${STAMP} "${S}"/pci.ids
+ fi
+ eend 0
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/share/man
+ make install PREFIX="${D}"/usr || die
+
+ dolib lib/libpci.* || die "libpci failed"
+ insinto /usr/include/pci
+ doins lib/{config,header,pci,types}.h || die "headers failed"
+}