summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:58:10 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-12-01 14:58:10 +0000
commitecec3ef8065bcc026db939590e782cc347a478da (patch)
treeb08985293485c4190cb05178174e6802c1af7c2c
parentVersion bump to 4.6.0 (diff)
downloadgentoo-2-ecec3ef8065bcc026db939590e782cc347a478da.tar.gz
gentoo-2-ecec3ef8065bcc026db939590e782cc347a478da.tar.bz2
gentoo-2-ecec3ef8065bcc026db939590e782cc347a478da.zip
Version bump to 4.6.0
(Portage version: 2.2_rc54/cvs/Linux x86_64)
-rw-r--r--x11-libs/qt-script/ChangeLog8
-rw-r--r--x11-libs/qt-script/qt-script-4.6.0.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-libs/qt-script/ChangeLog b/x11-libs/qt-script/ChangeLog
index 9a99cafead9b..13c990842e55 100644
--- a/x11-libs/qt-script/ChangeLog
+++ b/x11-libs/qt-script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-script
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.54 2009/11/18 20:49:15 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/ChangeLog,v 1.55 2009/12/01 14:58:10 tampakrap Exp $
+
+*qt-script-4.6.0 (01 Dec 2009)
+
+ 01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-script-4.6.0.ebuild:
+ Version Bump to 4.6.0
*qt-script-4.6.0_rc1 (18 Nov 2009)
diff --git a/x11-libs/qt-script/qt-script-4.6.0.ebuild b/x11-libs/qt-script/qt-script-4.6.0.ebuild
new file mode 100644
index 000000000000..70ac100a7693
--- /dev/null
+++ b/x11-libs/qt-script/qt-script-4.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-script/qt-script-4.6.0.ebuild,v 1.1 2009/12/01 14:58:10 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The ECMAScript module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/script/"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtScript/
+src/corelib/
+src/3rdparty/javascriptcore/
+"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -script -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-opengl -no-svg -no-gtkstyle"
+ qt4-build_src_configure
+}