summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-23 06:13:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-23 06:13:28 +0000
commitecbf4e4bdcc8696223256378a891b49b785d2d3c (patch)
treecadf471bc91d5a86c7a373d0cd1aac99cb55dc11
parentVersion bump to 1.2.1, bug 453236. (diff)
downloadgentoo-2-ecbf4e4bdcc8696223256378a891b49b785d2d3c.tar.gz
gentoo-2-ecbf4e4bdcc8696223256378a891b49b785d2d3c.tar.bz2
gentoo-2-ecbf4e4bdcc8696223256378a891b49b785d2d3c.zip
version bump (bug #452272)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-util/joystick/ChangeLog10
-rw-r--r--games-util/joystick/files/joystick-1.4.4-build.patch41
-rw-r--r--games-util/joystick/joystick-1.4.4.ebuild29
3 files changed, 78 insertions, 2 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index a6b9fc7fc9d5..47b79c5f339e 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/joystick
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.18 2012/06/14 14:45:16 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.19 2013/01/23 06:13:28 mr_bones_ Exp $
+
+*joystick-1.4.4 (23 Jan 2013)
+
+ 23 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/joystick-1.4.4-build.patch, +joystick-1.4.4.ebuild:
+ version bump (bug #452272)
14 Jun 2012; Michael Weber <xmw@gentoo.org> joystick-0_pre20060731.ebuild:
ppc stable (bug 403233)
diff --git a/games-util/joystick/files/joystick-1.4.4-build.patch b/games-util/joystick/files/joystick-1.4.4-build.patch
new file mode 100644
index 000000000000..8a74e82a4dba
--- /dev/null
+++ b/games-util/joystick/files/joystick-1.4.4-build.patch
@@ -0,0 +1,41 @@
+diff -ru linuxconsoletools-1.4.4.orig/docs/Makefile linuxconsoletools-1.4.4/docs/Makefile
+--- linuxconsoletools-1.4.4.orig/docs/Makefile 2011-12-15 10:49:01.000000000 -0500
++++ linuxconsoletools-1.4.4/docs/Makefile 2013-01-23 01:09:34.963691526 -0500
+@@ -20,13 +20,17 @@
+ # 02110-1301 USA.
+
+ MANPAGES = inputattach.1 jstest.1 jscal.1 fftest.1 \
+- ffmvforce.1 ffset.1 ffcfstress.1 jscal-store.1 \
++ ffset.1 ffcfstress.1 jscal-store.1 \
+ jscal-restore.1
+
++ifneq ($(USE_SDL),no)
++MANPAGES += ffmvforce.1
++endif
++
+ PREFIX ?= /usr/local
+
+ install:
+ install -d $(DESTDIR)$(PREFIX)/share/man/man1
+- install $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 644 $(MANPAGES) $(DESTDIR)$(PREFIX)/share/man/man1
+
+ .PHONY: install
+diff -ru linuxconsoletools-1.4.4.orig/utils/Makefile linuxconsoletools-1.4.4/utils/Makefile
+--- linuxconsoletools-1.4.4.orig/utils/Makefile 2012-09-05 02:34:53.000000000 -0400
++++ linuxconsoletools-1.4.4/utils/Makefile 2013-01-23 01:11:02.112760453 -0500
+@@ -27,9 +27,13 @@
+
+ CFLAGS ?= -g -O2 -Wall
+
+-PROGRAMS = inputattach jstest jscal fftest ffmvforce ffset \
++PROGRAMS = inputattach jstest jscal fftest ffset \
+ ffcfstress jscal-restore jscal-store
+
++ifneq ($(USE_SDL),no)
++PROGRAMS += ffmvforce
++endif
++
+ PREFIX ?= /usr/local
+
+ compile: $(PROGRAMS)
diff --git a/games-util/joystick/joystick-1.4.4.ebuild b/games-util/joystick/joystick-1.4.4.ebuild
new file mode 100644
index 000000000000..53ab6abd716b
--- /dev/null
+++ b/games-util/joystick/joystick-1.4.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-1.4.4.ebuild,v 1.1 2013/01/23 06:13:28 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="http://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="sdl"
+
+DEPEND="sdl? ( media-libs/libsdl[video] )
+ !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ export PREFIX=/usr
+ tc-export CC PKG_CONFIG
+ export USE_SDL=$(usex sdl)
+}