summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2006-08-12 21:30:24 +0000
committerJason Wever <weeve@gentoo.org>2006-08-12 21:30:24 +0000
commiteb1a8218b10bd8ec875a31a2aca944c9e6f4c387 (patch)
tree80643b9dfec078d62aa7a9b73df02c16c164d8a6
parentStable on amd64 per bug #143714 (diff)
downloadgentoo-2-eb1a8218b10bd8ec875a31a2aca944c9e6f4c387.tar.gz
gentoo-2-eb1a8218b10bd8ec875a31a2aca944c9e6f4c387.tar.bz2
gentoo-2-eb1a8218b10bd8ec875a31a2aca944c9e6f4c387.zip
Adjusted machine detection for SPARC as the native SPARC assembly routines math-pari tries to use results in unloadable C modules for perl.
(Portage version: 2.1.1_pre5)
-rw-r--r--dev-perl/math-pari/ChangeLog6
-rw-r--r--dev-perl/math-pari/math-pari-2.010706.ebuild9
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 4f2af1b327f2..3ee72982d826 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.28 2006/08/06 02:49:06 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.29 2006/08/12 21:30:24 weeve Exp $
+
+ 12 Aug 2006; Jason Wever <weeve@gentoo.org> math-pari-2.010706.ebuild:
+ Adjusted machine detection for SPARC as the native SPARC assembly routines
+ math-pari tries to use results in unloadable C modules for perl.
06 Aug 2006; Michael Cummings <mcummings@gentoo.org>
math-pari-2.010500-r1.ebuild, math-pari-2.010603.ebuild,
diff --git a/dev-perl/math-pari/math-pari-2.010706.ebuild b/dev-perl/math-pari/math-pari-2.010706.ebuild
index 8aa017671601..579d75125316 100644
--- a/dev-perl/math-pari/math-pari-2.010706.ebuild
+++ b/dev-perl/math-pari/math-pari-2.010706.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.3 2006/08/06 02:49:06 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010706.ebuild,v 1.4 2006/08/12 21:30:24 weeve Exp $
inherit perl-module eutils
@@ -26,3 +26,10 @@ DEPEND="~sci-mathematics/pari-2.1.7
dev-lang/perl"
RDEPEND="${DEPEND}"
+# Unfortunately the assembly routines math-pari has for SPARC do not appear
+# to be working at current. Perl cannot test math-pari or anything that pulls
+# in the math-pari module as DynaLoader cannot load the resulting .so files
+# math-pari generates. As such, we have to use the generic non-machine
+# specific assembly methods here.
+
+use sparc && myconf="${myconf} machine=none"