summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-20 06:43:51 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-20 06:43:51 +0000
commite86839f5184d64aa3ef1a7245622f6abe0c48100 (patch)
tree6b1f9d2cf10b8eb937f65c9d518b25652b40676f
parentAdding new use flags for commons-logging. (diff)
downloadgentoo-2-e86839f5184d64aa3ef1a7245622f6abe0c48100.tar.gz
gentoo-2-e86839f5184d64aa3ef1a7245622f6abe0c48100.tar.bz2
gentoo-2-e86839f5184d64aa3ef1a7245622f6abe0c48100.zip
Update configure.in patch to respect CXXFLAGS; Add patch for linking errors; Depend on dev-lang/swig, bug #144257
(Portage version: 2.1.2_pre3-r5)
-rw-r--r--games-rpg/adonthell/ChangeLog8
-rw-r--r--games-rpg/adonthell/adonthell-0.3.4a.ebuild7
-rw-r--r--games-rpg/adonthell/files/0.3.4a-configure.in.patch46
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.4a-inline.patch20
4 files changed, 63 insertions, 18 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index 0310ac6aed3d..9569d3bd4d26 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/adonthell
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.11 2006/09/23 12:18:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.12 2006/10/20 06:43:51 nyhm Exp $
+
+ 20 Oct 2006; Tristan Heaven <nyhm@gentoo.org>
+ +files/adonthell-0.3.4a-inline.patch, files/0.3.4a-configure.in.patch,
+ adonthell-0.3.4a.ebuild:
+ Update configure.in patch to respect CXXFLAGS; Add patch for linking errors;
+ Depend on dev-lang/swig, bug #144257
23 Sep 2006; Mike Frysinger <vapier@gentoo.org> adonthell-0.3.4a.ebuild:
Cleanup autotools #148762 by David Philippi.
diff --git a/games-rpg/adonthell/adonthell-0.3.4a.ebuild b/games-rpg/adonthell/adonthell-0.3.4a.ebuild
index 4f727278a21d..2deb599d8483 100644
--- a/games-rpg/adonthell/adonthell-0.3.4a.ebuild
+++ b/games-rpg/adonthell/adonthell-0.3.4a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.4a.ebuild,v 1.6 2006/09/23 12:18:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.4a.ebuild,v 1.7 2006/10/20 06:43:51 nyhm Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -20,7 +20,7 @@ RDEPEND="dev-lang/python
media-libs/libsdl
media-libs/libvorbis
media-libs/libogg
- sys-libs/zlib"
+ dev-lang/swig"
DEPEND="${RDEPEND}
doc? (
media-gfx/graphviz
@@ -34,7 +34,8 @@ src_unpack() {
cd "${S}"
epatch \
"${FILESDIR}"/${PV}-configure.in.patch \
- "${FILESDIR}"/${P}-gcc-41.patch
+ "${FILESDIR}"/${P}-gcc-41.patch \
+ "${FILESDIR}"/${P}-inline.patch
rm -f ac{local,include}.m4
AT_M4DIR="m4" eautoreconf
}
diff --git a/games-rpg/adonthell/files/0.3.4a-configure.in.patch b/games-rpg/adonthell/files/0.3.4a-configure.in.patch
index 9a3726133720..903bd9a5f67d 100644
--- a/games-rpg/adonthell/files/0.3.4a-configure.in.patch
+++ b/games-rpg/adonthell/files/0.3.4a-configure.in.patch
@@ -1,8 +1,17 @@
---- configure.in.orig 2005-03-12 18:01:25.000000000 -0500
-+++ configure.in 2005-03-13 00:12:26.000000000 -0500
-@@ -159,10 +159,8 @@
+--- configure.in
++++ configure.in
+@@ -13,7 +13,7 @@
+ AM_INIT_AUTOMAKE([])
+ AM_CONFIG_HEADER(config.h)
- dnl Extract the version using Python, check against 1.5+
+-CFLAGS="-g -Wall -fno-exceptions"
++CXXFLAGS="$CXXFLAGS -Wall -fno-exceptions"
+ CPPFLAGS=""
+ DEFS=""
+
+@@ -163,10 +163,8 @@
+
+ dnl Extract the version using Python, check against 2.2+
- changequote(<<, >>)
- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
@@ -11,9 +20,9 @@
+ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
+ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
- if test $PYTHON_VERSION -lt 15; then
- echo "Sorry, you need to have Python 1.5+ installed - update your version!"
-@@ -172,9 +170,7 @@
+ if test $PYTHON_VERSION -lt 22; then
+ echo "Sorry, you need to have Python 2.2+ installed - update your version!"
+@@ -176,9 +174,7 @@
dnl Find the Python.h header file
AC_MSG_CHECKING(for Python header files)
@@ -24,8 +33,8 @@
if test -r "$PYINCLUDE/Python.h"; then
PY_CFLAGS="-I$PYINCLUDE"
-@@ -188,10 +184,8 @@
-
+@@ -191,10 +187,8 @@
+ dnl Find the Python library
AC_MSG_CHECKING(for Python library)
PYLIB=""
- changequote(<<, >>)
@@ -34,10 +43,10 @@
- changequote([, ])
+ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
- py_paths="$PYPREFIX/lib/python$PYLIBVER/config $PYPREFIX/lib"
- py_suffix="$PYLIBVER.so $PYLIBVER.a .so .a"
-@@ -220,19 +214,9 @@
-
+ dnl look for a framework build of python first
+ fw=`echo "$PYPREFIX" | sed 's/.*\(Python\.framework\).*/\1/;'`
+@@ -233,19 +227,9 @@
+ fi
dnl Get the libraries that python depends on
- AC_PATH_PROG(haveldd, ldd)
@@ -57,7 +66,7 @@
case $target in
*-sun-solaris*)
-@@ -280,11 +264,9 @@
+@@ -293,11 +277,9 @@
if test "$P_SWIG" != "no" ; then
$P_SWIG -version &> swig.ver
@@ -72,3 +81,12 @@
rm -f swig.ver
+@@ -387,7 +369,7 @@
+ dnl Generate our compiler arguements
+ dnl ********************************
+
+-CXXFLAGS="$CFLAGS $DEFS $INCLUDES"
++CXXFLAGS="$CXXFLAGS $DEFS $INCLUDES"
+
+ AC_SUBST(CXX)
+ AC_SUBST(CXXFLAGS)
diff --git a/games-rpg/adonthell/files/adonthell-0.3.4a-inline.patch b/games-rpg/adonthell/files/adonthell-0.3.4a-inline.patch
new file mode 100644
index 000000000000..445f3b1ac58d
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.4a-inline.patch
@@ -0,0 +1,20 @@
+--- src/label.cc
++++ src/label.cc
+@@ -186,7 +186,7 @@
+ /**
+ Set if cursor is visible
+ */
+-inline void label::set_cursor_visible (const bool b)
++void label::set_cursor_visible (const bool b)
+ {
+ visible_cursor_ = b;
+ }
+@@ -195,7 +195,7 @@
+ /**
+ Set the cursor moveable with arrow
+ */
+-inline void label::set_cursor_moveable (const bool b)
++void label::set_cursor_moveable (const bool b)
+ {
+ moveable_cursor_ = b;
+ }