summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2003-05-17 19:52:51 +0000
committerHanno Böck <hanno@gentoo.org>2003-05-17 19:52:51 +0000
commite7a6a3b38ae9a195ba8a748b3c18d0614e296e2e (patch)
treeb52a9f000444b6dde75211eb4c7ae4b58106f7f0
parentMarked as stable. (diff)
downloadgentoo-2-e7a6a3b38ae9a195ba8a748b3c18d0614e296e2e.tar.gz
gentoo-2-e7a6a3b38ae9a195ba8a748b3c18d0614e296e2e.tar.bz2
gentoo-2-e7a6a3b38ae9a195ba8a748b3c18d0614e296e2e.zip
new xlockmore version
-rw-r--r--app-misc/xlockmore/Manifest5
-rw-r--r--app-misc/xlockmore/files/digest-xlockmore-5.08.21
-rw-r--r--app-misc/xlockmore/xlockmore-5.08.2.ebuild68
3 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/xlockmore/Manifest b/app-misc/xlockmore/Manifest
new file mode 100644
index 000000000000..b610c6397d7f
--- /dev/null
+++ b/app-misc/xlockmore/Manifest
@@ -0,0 +1,5 @@
+MD5 22d376143131e84b2ef0194746db459a ChangeLog 3051
+MD5 b3fc6924c7dd6703e3d4c4150a0f8d9b xlockmore-5.04.ebuild 1839
+MD5 8d77be658675e06edf93db000aabf051 xlockmore-5.08.2.ebuild 1846
+MD5 589c4732f3e791a2cad0f52c7ec09908 files/digest-xlockmore-5.04 68
+MD5 7c6285fb6c9ff44a2590f166ecd553ef files/digest-xlockmore-5.08.2 70
diff --git a/app-misc/xlockmore/files/digest-xlockmore-5.08.2 b/app-misc/xlockmore/files/digest-xlockmore-5.08.2
new file mode 100644
index 000000000000..6472be082d1e
--- /dev/null
+++ b/app-misc/xlockmore/files/digest-xlockmore-5.08.2
@@ -0,0 +1 @@
+MD5 c122f9a99133dff896c989f148d97567 xlockmore-5.08.2.tar.bz2 1555399
diff --git a/app-misc/xlockmore/xlockmore-5.08.2.ebuild b/app-misc/xlockmore/xlockmore-5.08.2.ebuild
new file mode 100644
index 000000000000..a44eecaab679
--- /dev/null
+++ b/app-misc/xlockmore/xlockmore-5.08.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/xlockmore/xlockmore-5.08.2.ebuild,v 1.1 2003/05/17 19:52:35 hanno Exp $
+
+IUSE="nas esd motif opengl truetype gtk pam"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.bz2"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/x11
+ media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( virtual/motif )
+ gtk? ( x11-libs/gtk+ )"
+
+src_compile() {
+ local myconf
+ myconf="--enable-vtlock"
+ use pam && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+ use nas || myconf="${myconf} --without-nas"
+ use esd && myconf="${myconf} --with-esound"
+ use opengl || myconf="${myconf} --without-opengl --without-gltt --without-mesa"
+ use truetype || myconf="${myconf} --without-ttf"
+
+ use motif || myconf="${myconf} --without-motif"
+ use gtk || myconf="${myconf} --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} ${myconf} || die "Configure failed"
+
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ || die "Install failed"
+
+ #Install pam.d file and unset setuid root
+ if use pam; then
+ insinto /etc/pam.d
+ newins etc/xlock.pamd xlock
+ chmod 111 ${D}/usr/bin/xlock
+ fi
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+ dodoc docs/* README
+ dohtml docs/*.html
+ rm ${D}/usr/share/doc/${PF}/*.html.gz
+}