summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-14 21:53:20 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-14 21:53:20 +0000
commite6d5dbe84552866f1dd1ce3f7c283e77ea6dedd0 (patch)
tree1332a6c0934918f7e8af2517c17ba23a7b5b4cb9
parentFix python_mod_cleanup (diff)
downloadgentoo-2-e6d5dbe84552866f1dd1ce3f7c283e77ea6dedd0.tar.gz
gentoo-2-e6d5dbe84552866f1dd1ce3f7c283e77ea6dedd0.tar.bz2
gentoo-2-e6d5dbe84552866f1dd1ce3f7c283e77ea6dedd0.zip
Bump to 2.24.2-r1, add patch to fix SIGBUS on sparc, bug #250830. Refix doc generation, bug #242868.
(Portage version: 2.2_rc17/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64, RepoMan options: --force)
-rw-r--r--media-gfx/eog/ChangeLog9
-rw-r--r--media-gfx/eog/eog-2.24.2-r1.ebuild81
-rw-r--r--media-gfx/eog/files/eog-2.24.2-sigbus.patch19
3 files changed, 108 insertions, 1 deletions
diff --git a/media-gfx/eog/ChangeLog b/media-gfx/eog/ChangeLog
index 72661b7b1ec1..d793e583a553 100644
--- a/media-gfx/eog/ChangeLog
+++ b/media-gfx/eog/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/eog
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.219 2008/12/11 10:14:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/ChangeLog,v 1.220 2008/12/14 21:53:20 eva Exp $
+
+*eog-2.24.2-r1 (14 Dec 2008)
+
+ 14 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/eog-2.24.2-sigbus.patch, +eog-2.24.2-r1.ebuild:
+ Bump to 2.24.2-r1, add patch to fix SIGBUS on sparc, bug #250830.
+ Refix doc generation, bug #242868.
11 Dec 2008; Raúl Porcel <armin76@gentoo.org> eog-2.24.2.ebuild:
Add ~alpha/~ia64 wrt #242812
diff --git a/media-gfx/eog/eog-2.24.2-r1.ebuild b/media-gfx/eog/eog-2.24.2-r1.ebuild
new file mode 100644
index 000000000000..feef76e071a7
--- /dev/null
+++ b/media-gfx/eog/eog-2.24.2-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/eog/eog-2.24.2-r1.ebuild,v 1.1 2008/12/14 21:53:20 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="The Eye of GNOME image viewer"
+HOMEPAGE="http://www.gnome.org/projects/eog/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~x86"
+IUSE="dbus doc exif lcms python xmp"
+
+RDEPEND=">=x11-libs/gtk+-2.13.1
+ >=dev-libs/glib-2.15.3
+ >=gnome-base/libgnomeui-2.10
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/gconf-2.5.90
+ >=media-libs/libart_lgpl-2.3.16
+ >=gnome-base/gnome-desktop-2.10
+ >=x11-themes/gnome-icon-theme-2.19.1
+ >=x11-misc/shared-mime-info-0.20
+ dbus? ( >=dev-libs/dbus-glib-0.71 )
+ exif? (
+ >=media-libs/libexif-0.6.14
+ media-libs/jpeg )
+ lcms? ( media-libs/lcms )
+ python? (
+ >=dev-lang/python-2.3
+ >=dev-python/pygobject-2.11.5
+ >=dev-python/pygtk-2.9.7
+ >=dev-python/gnome-python-2.18.2 )
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.17
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with exif libjpeg)
+ $(use_with exif libexif)
+ $(use_with dbus)
+ $(use_with lcms cms)
+ $(use_enable python)
+ $(use_with xmp)
+ --disable-scrollkeeper
+ --disable-schemas-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix documentation with USE="-exif doc"
+ sed 's:-I$(top_srcdir)/plugins \\:\\:g' \
+ -i doc/reference/Makefile.am doc/reference/Makefile.in \
+ || die "sed failed"
+
+ # Fix sigbus on sparc, bug #250830
+ epatch "${FILESDIR}/${P}-sigbus.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! built_with_use =x11-libs/gtk+-2* jpeg; then
+ ewarn "For JPEG file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'jpeg' USE flag enabled."
+ fi
+
+ if ! built_with_use =x11-libs/gtk+-2* tiff; then
+ ewarn "For TIFF file support to work, x11-libs/gtk+ must be rebuilt"
+ ewarn "with the 'tiff' USE flag enabled."
+ fi
+}
diff --git a/media-gfx/eog/files/eog-2.24.2-sigbus.patch b/media-gfx/eog/files/eog-2.24.2-sigbus.patch
new file mode 100644
index 000000000000..6f050f62f809
--- /dev/null
+++ b/media-gfx/eog/files/eog-2.24.2-sigbus.patch
@@ -0,0 +1,19 @@
+---
+ http://bugzilla.gnome.org/show_bug.cgi?id=564526
+ https://bugs.gentoo.org/show_bug.cgi?id=250830
+
+ eog-metadata-reader-png.c | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+--- a/src/eog-metadata-reader-png.c
++++ b/src/eog-metadata-reader-png.c
+@@ -369,8 +369,7 @@
+ if (priv->state == EMR_CHECK_CRC) {
+ /* Check if it is actually an XMP chunk.
+ * Throw it away if not. */
+- if ((memcmp (priv->xmp_chunk, "XML:com.adobe.xmp\0", 18) != 0)
+- || (*(guint32*)(priv->xmp_chunk+18)) != 0) {
++ if (memcmp (priv->xmp_chunk, "XML:com.adobe.xmp\0\0\0\0\0", 22) != 0) {
+ priv->state = EMR_SKIP_CRC;
+ g_free (priv->xmp_chunk);
+ priv->xmp_chunk = NULL;