summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-12-27 17:08:26 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-12-27 17:08:26 +0000
commite6510f6046b1fbc7eef4aa6bc0fdf80398d72a0a (patch)
tree69ca82eff709e1dd732608ccc18846fbefa75b92
parentMask 'context' USE-flag for dev-libs/boost (diff)
downloadgentoo-2-e6510f6046b1fbc7eef4aa6bc0fdf80398d72a0a.tar.gz
gentoo-2-e6510f6046b1fbc7eef4aa6bc0fdf80398d72a0a.tar.bz2
gentoo-2-e6510f6046b1fbc7eef4aa6bc0fdf80398d72a0a.zip
Revision bump: implement conditional building of Boost.Context library via 'context' USE-flag. Drop old revision
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
-rw-r--r--dev-libs/boost/ChangeLog9
-rw-r--r--dev-libs/boost/boost-1.55.0-r1.ebuild (renamed from dev-libs/boost/boost-1.55.0.ebuild)11
-rw-r--r--dev-libs/boost/metadata.xml4
3 files changed, 19 insertions, 5 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 0c70abfe4040..07a710999882 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.310 2013/12/27 16:59:47 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.311 2013/12/27 17:08:26 pinkbyte Exp $
+
+*boost-1.55.0-r1 (27 Dec 2013)
+
+ 27 Dec 2013; Sergey Popov <pinkbyte@gentoo.org> -boost-1.55.0.ebuild,
+ +boost-1.55.0-r1.ebuild, metadata.xml:
+ Revision bump: implement conditional building of Boost.Context library via
+ 'context' USE-flag. Drop old revision
*boost-1.54.0-r1 (27 Dec 2013)
*boost-1.53.0-r1 (27 Dec 2013)
diff --git a/dev-libs/boost/boost-1.55.0.ebuild b/dev-libs/boost/boost-1.55.0-r1.ebuild
index 683f2cb93165..2ef0257f2f41 100644
--- a/dev-libs/boost/boost-1.55.0.ebuild
+++ b/dev-libs/boost/boost-1.55.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0.ebuild,v 1.3 2013/11/30 20:32:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.55.0-r1.ebuild,v 1.1 2013/12/27 17:08:26 pinkbyte Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -18,7 +18,7 @@ LICENSE="Boost-1.0"
SLOT="0/${PV}" # ${PV} instead ${MAJOR_V} due to bug 486122
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
-IUSE="debug doc icu +nls mpi python static-libs +threads tools"
+IUSE="context debug doc icu +nls mpi python static-libs +threads tools"
RDEPEND="icu? ( >=dev-libs/icu-3.6:= )
!icu? ( virtual/libiconv )
@@ -116,12 +116,12 @@ src_configure() {
use mpi || OPTIONS+=" --without-mpi"
use python || OPTIONS+=" --without-python"
use nls || OPTIONS+=" --without-locale"
+ use context || OPTIONS+=" --without-context --without-coroutine"
OPTIONS+=" pch=off"
OPTIONS+=" --boost-build=${EPREFIX}/usr/share/boost-build --prefix=\"${ED}usr\""
OPTIONS+=" --layout=system"
OPTIONS+=" threading=$(usex threads multi single) link=$(usex static-libs shared,static shared)"
- OPTIONS+=" --without-context"
[[ ${CHOST} == *-winnt* ]] && OPTIONS+=" -sNO_BZIP2=1"
}
@@ -252,7 +252,10 @@ EOF
rm -r "${ED}"/usr/include/boost/locale || die
fi
- rm -r "${ED}"/usr/include/boost/context || die
+ if ! use context; then
+ rm -r "${ED}"/usr/include/boost/context || die
+ rm -r "${ED}"/usr/include/boost/coroutine || die
+ fi
if use doc; then
find libs/*/* -iname "test" -or -iname "src" | xargs rm -rf
diff --git a/dev-libs/boost/metadata.xml b/dev-libs/boost/metadata.xml
index 9c5d65685883..03f221b7e919 100644
--- a/dev-libs/boost/metadata.xml
+++ b/dev-libs/boost/metadata.xml
@@ -3,6 +3,10 @@
<pkgmetadata>
<herd>cpp</herd>
<use>
+ <flag name='context'>
+ Build and install the Boost.Context library and all other
+ Boostlibraries that depends on it
+ </flag>
<flag name='tools'>
Build and install the boost tools (bcp, quickbook, inspect,
wave)