summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 03:35:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-14 03:35:45 +0000
commite5419f067150d3279f683bc97e556bcd2d43c3ec (patch)
tree88f2e08843f733e52141b67c2da7d8353b0b0fc9
parentFix up dependencies, especially for tests. (diff)
downloadgentoo-2-e5419f067150d3279f683bc97e556bcd2d43c3ec.tar.gz
gentoo-2-e5419f067150d3279f683bc97e556bcd2d43c3ec.tar.bz2
gentoo-2-e5419f067150d3279f683bc97e556bcd2d43c3ec.zip
Bump to EAPI 4; use RUBY_PATCHES to add the patches; use the ruby-ng helpers for rspec and testrb-2.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--dev-ruby/fakefs/ChangeLog7
-rw-r--r--dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild31
2 files changed, 25 insertions, 13 deletions
diff --git a/dev-ruby/fakefs/ChangeLog b/dev-ruby/fakefs/ChangeLog
index 4e8ffa41d642..bccf6f71740b 100644
--- a/dev-ruby/fakefs/ChangeLog
+++ b/dev-ruby/fakefs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/fakefs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakefs/ChangeLog,v 1.23 2012/05/20 18:28:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakefs/ChangeLog,v 1.24 2012/08/14 03:35:45 flameeyes Exp $
+
+ 14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> fakefs-0.4.0-r1.ebuild:
+ Bump to EAPI 4; use RUBY_PATCHES to add the patches; use the ruby-ng helpers
+ for rspec and testrb-2.
20 May 2012; Hans de Graaff <graaff@gentoo.org> fakefs-0.4.0-r1.ebuild:
Add jruby but ignore some tests similar to upstream. Needed for newer rspec:2
@@ -86,4 +90,3 @@
12 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+fakefs-0.2.1.ebuild, +files/fakefs-0.2.1-ruby19.patch, +metadata.xml:
Initial import of fakefs as needed by rspec testsuite.
-
diff --git a/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild b/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild
index 48085205f663..df21187af882 100644
--- a/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild
+++ b/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild
@@ -1,14 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild,v 1.2 2012/05/20 18:28:15 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fakefs/fakefs-0.4.0-r1.ebuild,v 1.3 2012/08/14 03:35:45 flameeyes Exp $
-EAPI=2
+EAPI=4
-# jruby → Marshal/DeMarshal to clone directories fail; tests fail in
-# release 0.2.1
USE_RUBY="ruby18 ree18 ruby19 jruby"
-RUBY_FAKEGEM_TASK_TEST="test spec"
+RUBY_FAKEGEM_RECIPE_TEST="none"
# requires sdoc
RUBY_FAKEGEM_TASK_DOC=""
@@ -25,16 +23,22 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""
-ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/rspec:2
+ >=dev-ruby/test-unit-2.5.1-r1
+ )"
+
+RUBY_PATCHES=(
+ "${P}-ruby193.patch"
+ "${P}-ruby193-advise.patch"
+ "${P}-ruby193-pathname.patch"
+ "${P}-ruby193-ruby-pathname.patch"
+)
all_ruby_prepare() {
# Remove bundler
rm Gemfile || die
-
- epatch "${FILESDIR}/${P}-ruby193.patch"
- epatch "${FILESDIR}/${P}-ruby193-advise.patch"
- epatch "${FILESDIR}/${P}-ruby193-pathname.patch"
- epatch "${FILESDIR}/${P}-ruby193-ruby-pathname.patch"
}
each_ruby_prepare() {
@@ -48,3 +52,8 @@ each_ruby_prepare() {
;;
esac
}
+
+each_ruby_test() {
+ ruby-ng_rspec
+ ruby-ng_testrb-2 -Ilib:test test/**/*_test.rb
+}