summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-25 05:20:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-25 05:20:13 +0000
commite444c2031e952385bf81a95e346cf7f5f0253ddd (patch)
tree5f6a67a974fd8d20b39bc23b8a1282d562217341
parentRemoving vulnerable ebuild. bug #539164 (diff)
downloadgentoo-2-e444c2031e952385bf81a95e346cf7f5f0253ddd.tar.gz
gentoo-2-e444c2031e952385bf81a95e346cf7f5f0253ddd.tar.bz2
gentoo-2-e444c2031e952385bf81a95e346cf7f5f0253ddd.zip
Bump
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/pyopencl/ChangeLog9
-rw-r--r--dev-python/pyopencl/pyopencl-2015.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-python/pyopencl/ChangeLog b/dev-python/pyopencl/ChangeLog
index 1b57f94efbcc..f904667301d1 100644
--- a/dev-python/pyopencl/ChangeLog
+++ b/dev-python/pyopencl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyopencl
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.28 2014/12/25 19:22:00 mgorny Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/ChangeLog,v 1.29 2015/02/25 05:20:13 patrick Exp $
+
+*pyopencl-2015.1 (25 Feb 2015)
+
+ 25 Feb 2015; Patrick Lauer <patrick@gentoo.org> +pyopencl-2015.1.ebuild:
+ Bump
25 Dec 2014; Michał Górny <mgorny@gentoo.org> pyopencl-2014.1.ebuild,
pyopencl-9999.ebuild:
diff --git a/dev-python/pyopencl/pyopencl-2015.1.ebuild b/dev-python/pyopencl/pyopencl-2015.1.ebuild
new file mode 100644
index 000000000000..2e1968012a98
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2015.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyopencl/pyopencl-2015.1.ebuild,v 1.1 2015/02/25 05:20:13 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="http://mathema.tician.de/software/pyopencl http://pypi.python.org/pypi/pyopencl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/pytools[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}