summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-01-03 22:06:53 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-01-03 22:06:53 +0000
commite413cb2eaebd455d80957d3761af7863fdaffb85 (patch)
tree8179dbf2b1d2b552072d4638359954916e9b3e58
parentstable x86, bug #347676; cleanup; eapi=2 (diff)
downloadgentoo-2-e413cb2eaebd455d80957d3761af7863fdaffb85.tar.gz
gentoo-2-e413cb2eaebd455d80957d3761af7863fdaffb85.tar.bz2
gentoo-2-e413cb2eaebd455d80957d3761af7863fdaffb85.zip
Version bump.
(Portage version: 2.2.0_alpha12/cvs/Linux x86_64)
-rw-r--r--app-text/iso-codes/ChangeLog9
-rw-r--r--app-text/iso-codes/iso-codes-3.24.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 165607750160..1af31dfff0b0 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/iso-codes
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.97 2010/12/13 22:31:09 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.98 2011/01/03 22:06:53 eva Exp $
+
+*iso-codes-3.24 (03 Jan 2011)
+
+ 03 Jan 2011; Gilles Dartiguelongue <eva@gentoo.org> +iso-codes-3.24.ebuild:
+ Version bump.
*iso-codes-3.23 (13 Dec 2010)
diff --git a/app-text/iso-codes/iso-codes-3.24.ebuild b/app-text/iso-codes/iso-codes-3.24.ebuild
new file mode 100644
index 000000000000..9d547ed8ad53
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.24.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.24.ebuild,v 1.1 2011/01/03 22:06:53 eva Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ || die "sed in ${norm} folder failed"
+ fi
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}