summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2010-04-13 08:03:44 +0000
committerDirkjan Ochtman <djc@gentoo.org>2010-04-13 08:03:44 +0000
commite3c48edd29b9240133ee805cdd9c248fda61991a (patch)
tree3f9998973d0a6d6bb9f07ba4903af802ef1639ef
parentAdd the python herd to metadata, primary maintainer hasn't been touching this. (diff)
downloadgentoo-2-e3c48edd29b9240133ee805cdd9c248fda61991a.tar.gz
gentoo-2-e3c48edd29b9240133ee805cdd9c248fda61991a.tar.bz2
gentoo-2-e3c48edd29b9240133ee805cdd9c248fda61991a.zip
Version bump dev-python/werkzeug to 0.6.1.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
-rw-r--r--dev-python/werkzeug/ChangeLog7
-rw-r--r--dev-python/werkzeug/werkzeug-0.6.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/werkzeug/ChangeLog b/dev-python/werkzeug/ChangeLog
index 3793cc053db5..5e047a5cd913 100644
--- a/dev-python/werkzeug/ChangeLog
+++ b/dev-python/werkzeug/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/werkzeug
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.15 2010/03/10 17:52:22 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/ChangeLog,v 1.16 2010/04/13 08:03:44 djc Exp $
+
+*werkzeug-0.6.1 (13 Apr 2010)
+
+ 13 Apr 2010; Dirkjan Ochtman <djc@gentoo.org> +werkzeug-0.6.1.ebuild:
+ Version bump to 0.6.1.
10 Mar 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
werkzeug-0.6.ebuild:
diff --git a/dev-python/werkzeug/werkzeug-0.6.1.ebuild b/dev-python/werkzeug/werkzeug-0.6.1.ebuild
new file mode 100644
index 000000000000..88e6721f67ed
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.6.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/werkzeug/werkzeug-0.6.1.ebuild,v 1.1 2010/04/13 08:03:44 djc Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_P="Werkzeug-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/"
+SRC_URI="http://pypi.python.org/packages/source/W/Werkzeug/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools
+ app-arch/unzip
+ test? ( dev-python/py
+ dev-python/lxml
+ dev-python/nose
+ dev-python/simplejson )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES"
+
+src_test() {
+ distutils_src_test -e '^test_app$'
+}