summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-07-13 17:51:09 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-07-13 17:51:09 +0000
commite2f6b1fb446f6d17605f48e51b4431236d89bcf3 (patch)
treea705ec150100f9d58d0edda0b1cc68e13052b0e7
parentversion bump (diff)
downloadgentoo-2-e2f6b1fb446f6d17605f48e51b4431236d89bcf3.tar.gz
gentoo-2-e2f6b1fb446f6d17605f48e51b4431236d89bcf3.tar.bz2
gentoo-2-e2f6b1fb446f6d17605f48e51b4431236d89bcf3.zip
compile fixes
(Portage version: 2.0.51.22-r1)
-rw-r--r--net-print/omni/Manifest14
-rw-r--r--net-print/omni/files/omni-0.9.1-cxx.patch12
-rw-r--r--net-print/omni/files/omni-0.9.1-errno.patch11
-rw-r--r--net-print/omni/omni-0.9.1.ebuild11
4 files changed, 36 insertions, 12 deletions
diff --git a/net-print/omni/Manifest b/net-print/omni/Manifest
index d4bf9e08cbc1..ee0b2aa3c048 100644
--- a/net-print/omni/Manifest
+++ b/net-print/omni/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 c41bc1e65ede00dc0e0b9ed1a41336bc omni-0.9.1.ebuild 1422
+MD5 30890975056cef03f2a1b4ae5c350492 omni-0.9.1.ebuild 1550
MD5 36c8b5a0eab6b33bf4f22c8f8176f876 ChangeLog 1093
MD5 1d0faaeaf12b2b9e9c257d3d91411d94 omni-0.9.2.ebuild 1778
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
+MD5 5ac5239eed788d2da1fc56a3591180f4 files/omni-0.9.1-errno.patch 454
MD5 b4fb01c3394f59f16ff3ecffb7457ec1 files/digest-omni-0.9.1 63
MD5 49f24c62ec6b52af1a05fde619ed383b files/digest-omni-0.9.2 277
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFC0UW/evY57Fted3ERAs1kAJ9GU+11gpXXQL8kNFHIkym20s4BLwCfVmwG
-LkEfjQyVEs9CspyuVZk2mxA=
-=YqoN
------END PGP SIGNATURE-----
+MD5 6fc70b575cf1e4bca1b30feddcd203ae files/omni-0.9.1-cxx.patch 436
diff --git a/net-print/omni/files/omni-0.9.1-cxx.patch b/net-print/omni/files/omni-0.9.1-cxx.patch
new file mode 100644
index 000000000000..b258283391f2
--- /dev/null
+++ b/net-print/omni/files/omni-0.9.1-cxx.patch
@@ -0,0 +1,12 @@
+diff -ur Omni/OmniPDCProxy.cpp ../../Omni.patch2/OmniPDCProxy.cpp
+--- Omni/OmniPDCProxy.cpp 2003-11-18 00:13:21.000000000 +0100
++++ ../../Omni.patch2/OmniPDCProxy.cpp 2005-06-28 01:51:11.000000000 +0200
+@@ -787,7 +787,7 @@
+ && PDCCMD_ACK == pCmd_d->getCommandType ()
+ )
+ {
+- pCmd_d->getCommandInt ((int)eOmniClass_d);
++ pCmd_d->getCommandInt ((int&)eOmniClass_d);
+ }
+ else
+ {
diff --git a/net-print/omni/files/omni-0.9.1-errno.patch b/net-print/omni/files/omni-0.9.1-errno.patch
new file mode 100644
index 000000000000..6cfd615238c2
--- /dev/null
+++ b/net-print/omni/files/omni-0.9.1-errno.patch
@@ -0,0 +1,11 @@
+diff -ur Omni/DeviceScaling.cpp ../../Omni.patch/DeviceScaling.cpp
+--- Omni/DeviceScaling.cpp 2003-12-12 00:11:28.000000000 +0100
++++ ../../Omni.patch/DeviceScaling.cpp 2005-06-27 17:01:30.000000000 +0200
+@@ -16,6 +16,7 @@
+ * along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <errno.h>
+ #include "DeviceScaling.hpp"
+ #include "JobProperties.hpp"
+
diff --git a/net-print/omni/omni-0.9.1.ebuild b/net-print/omni/omni-0.9.1.ebuild
index 8d474dc8c4bb..756ff4b552e2 100644
--- a/net-print/omni/omni-0.9.1.ebuild
+++ b/net-print/omni/omni-0.9.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.1.ebuild,v 1.3 2005/07/10 15:56:12 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.1.ebuild,v 1.4 2005/07/13 17:51:09 lanius Exp $
+
+inherit eutils
DESCRIPTION="Omni provides support for many printers with a pluggable framework (easy to add devices)"
HOMEPAGE="http://sourceforge.net/projects/omniprint"
@@ -21,6 +23,13 @@ S="${WORKDIR}/Omni"
IUSE="cups X ppds foomaticdb static"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-errno.patch
+ epatch ${FILESDIR}/${P}-cxx.patch
+}
+
src_compile() {
local myconf=" \
$(use_enable X jobdialog) \