summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-09 00:22:08 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-09 00:22:08 +0000
commite2e997a04f6e20afee213545a48689f378f3815b (patch)
treedefe17413147d6b941eaa4ac0542a649dcc3ec3a
parentamd64, ppc and x86 stable, wrt bug #465066 (diff)
downloadgentoo-2-e2e997a04f6e20afee213545a48689f378f3815b.tar.gz
gentoo-2-e2e997a04f6e20afee213545a48689f378f3815b.tar.bz2
gentoo-2-e2e997a04f6e20afee213545a48689f378f3815b.zip
Version bump.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--dev-java/commons-io/ChangeLog9
-rw-r--r--dev-java/commons-io/commons-io-2.4.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-java/commons-io/ChangeLog b/dev-java/commons-io/ChangeLog
index b4d10ba12c0b..74ec58acd351 100644
--- a/dev-java/commons-io/ChangeLog
+++ b/dev-java/commons-io/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/commons-io
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.54 2012/01/01 12:16:29 sera Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/ChangeLog,v 1.55 2013/04/09 00:22:08 radhermit Exp $
+
+*commons-io-2.4 (09 Apr 2013)
+
+ 09 Apr 2013; Tim Harder <radhermit@gentoo.org> +commons-io-2.4.ebuild:
+ Version bump.
01 Jan 2012; Ralph Sennhauser <sera@gentoo.org> commons-io-1.4.ebuild,
commons-io-2.0.1.ebuild:
diff --git a/dev-java/commons-io/commons-io-2.4.ebuild b/dev-java/commons-io/commons-io-2.4.ebuild
new file mode 100644
index 000000000000..39ad1a789fd7
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-2.4.ebuild,v 1.1 2013/04/09 00:22:08 radhermit Exp $
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P=${P}-src
+DESCRIPTION="Commons-IO contains utility classes, stream implementations, file filters, and endian classes."
+HOMEPAGE="http://commons.apache.org/io/"
+SRC_URI="mirror://apache/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+EANT_EXTRA_ARGS="-Dcomponent.version=${PV}"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ # Setting java.io.tmpdir doesn't have effect unless we do this because the vm is forked
+ java-ant_xml-rewrite -f build.xml --change -e junit -a clonevm -v "true"
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] ; then
+ ANT_OPTS="-Dskip.download=1 -Djava.io.tmpdir=${T} -Duser.home=${T}" \
+ ANT_TASKS="ant-junit" \
+ eant test \
+ -Dgentoo.classpath="$(java-pkg_getjars junit-4):${S}/src/test/resources" \
+ -Dlibdir="libdir" \
+ -Djava.io.tmpdir="${T}"
+ else
+ elog "Tests fail unless userpriv is enabled because they test for"
+ elog "file permissions which doesn't work when run as root."
+ fi
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}