summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-17 10:47:22 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-17 10:47:22 +0000
commite2d524c2790729b14ab4fe98c0c5bd53ed7530c3 (patch)
tree3282319681f03c279465ed8d8f3fb6ae3709e7a6
parentUSE musicbrainz wrt #175495, thanks to Pacho Ramos for reporting. (diff)
downloadgentoo-2-e2d524c2790729b14ab4fe98c0c5bd53ed7530c3.tar.gz
gentoo-2-e2d524c2790729b14ab4fe98c0c5bd53ed7530c3.tar.bz2
gentoo-2-e2d524c2790729b14ab4fe98c0c5bd53ed7530c3.zip
Tweak deps a bit.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
-rw-r--r--media-sound/listen/listen-0.6.2.ebuild11
-rw-r--r--media-sound/listen/metadata.xml1
2 files changed, 7 insertions, 5 deletions
diff --git a/media-sound/listen/listen-0.6.2.ebuild b/media-sound/listen/listen-0.6.2.ebuild
index 88077ff1ff32..35e68fd39848 100644
--- a/media-sound/listen/listen-0.6.2.ebuild
+++ b/media-sound/listen/listen-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.6.2.ebuild,v 1.3 2009/07/17 10:26:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/listen/listen-0.6.2.ebuild,v 1.4 2009/07/17 10:47:22 ssuominen Exp $
EAPI=2
inherit eutils multilib python
@@ -12,15 +12,16 @@ SRC_URI="http://download.listen-project.org/lastest/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="hal ipod +libsexy musicbrainz"
+IUSE="hal ipod +libsexy musicbrainz +webkit"
RDEPEND=">=dev-lang/python-2.5
- >=dev-python/pygtk-2.6:2
+ >=dev-python/pygtk-2.8:2
|| ( dev-python/python-xlib dev-python/egg-python )
media-libs/mutagen
dev-python/gst-python:0.10
media-plugins/gst-plugins-meta:0.10
- || ( dev-python/pywebkitgtk dev-python/gtkmozembed-python )
+ webkit? ( dev-python/pywebkitgtk )
+ !webkit? ( dev-python/gtkmozembed-python )
dev-python/pyinotify
libsexy? ( dev-python/sexy-python )
ipod? ( media-libs/libgpod[python] )
@@ -40,7 +41,7 @@ src_prepare() {
}
src_compile() {
- if has_version dev-python/pywebkitgtk; then
+ if use webkit; then
CHECK_DEPENDS="0" emake || die "emake failed"
else
USE_GTKMOZEMBED="1" CHECK_DEPENDS="0" emake || die "emake failed"
diff --git a/media-sound/listen/metadata.xml b/media-sound/listen/metadata.xml
index 10ef54c9b01c..de23194828af 100644
--- a/media-sound/listen/metadata.xml
+++ b/media-sound/listen/metadata.xml
@@ -33,5 +33,6 @@
</longdescription>
<use>
<flag name="libsexy">Enable libsexy support</flag>
+ <flag name="webkit">Enable webkit rendering engine instead of mozembed</flag>
</use>
</pkgmetadata>