summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-04-22 21:52:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-04-22 21:52:53 +0000
commite21b2745d048c53b10e45d1d141e4a324fed247e (patch)
tree481f359736539aadcb7ff55c3f332063720762f4
parentSwitched to distutils-r1 (diff)
downloadgentoo-2-e21b2745d048c53b10e45d1d141e4a324fed247e.tar.gz
gentoo-2-e21b2745d048c53b10e45d1d141e4a324fed247e.tar.bz2
gentoo-2-e21b2745d048c53b10e45d1d141e4a324fed247e.zip
Version bump
(Portage version: 2.2.01.21890-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
-rw-r--r--dev-python/pyds9/ChangeLog9
-rw-r--r--dev-python/pyds9/pyds9-1.6.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pyds9/ChangeLog b/dev-python/pyds9/ChangeLog
index 8410c8b44144..7a1b2f82488f 100644
--- a/dev-python/pyds9/ChangeLog
+++ b/dev-python/pyds9/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyds9
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds9/ChangeLog,v 1.7 2012/08/21 11:55:00 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds9/ChangeLog,v 1.8 2013/04/22 21:52:53 bicatali Exp $
+
+*pyds9-1.6 (22 Apr 2013)
+
+ 22 Apr 2013; Sébastien Fabbro <bicatali@gentoo.org> +pyds9-1.6.ebuild:
+ Version bump
*pyds9-1.5 (21 Aug 2012)
diff --git a/dev-python/pyds9/pyds9-1.6.ebuild b/dev-python/pyds9/pyds9-1.6.ebuild
new file mode 100644
index 000000000000..26eb7a5884fe
--- /dev/null
+++ b/dev-python/pyds9/pyds9-1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyds9/pyds9-1.6.ebuild,v 1.1 2013/04/22 21:52:53 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} )
+inherit distutils-r1 multilib
+
+XPAPV=2.1.14
+
+DESCRIPTION="Python interface to XPA to communicate with DS9"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9/pyds9/"
+SRC_URI="http://hea-www.harvard.edu/RD/download/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=x11-libs/xpa-${XPAPV}"
+RDEPEND="${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyfits[${PYTHON_USEDEP}]"
+
+DOCS=(changelog README)
+
+src_prepare() {
+ rm -r xpa-${XPAPV} || die
+ sed -i \
+ -e "/py_modules/s|\],|\])|" \
+ -e '/data_files/,$ d' \
+ setup.py || die
+ sed -i \
+ -e "s|./xpa-${XPAPV}|${EROOT}/usr/$(get_libdir)|" \
+ xpa.py || die
+ sed -i \
+ -e "s|sys.path|${EROOT}/usr/bin|" \
+ ds9.py || die
+ distutils-r1_src_prepare
+}