summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-04-23 14:42:25 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-04-23 14:42:25 +0000
commite1ad7c2b4fed419ca7993605675f00dc5c09353c (patch)
tree19c5849bdae6d9a514f9f5bf40c8be9cbe89f562
parentrevision for thunderbird 1.5.0.2 (diff)
downloadgentoo-2-e1ad7c2b4fed419ca7993605675f00dc5c09353c.tar.gz
gentoo-2-e1ad7c2b4fed419ca7993605675f00dc5c09353c.tar.bz2
gentoo-2-e1ad7c2b4fed419ca7993605675f00dc5c09353c.zip
fix for bug #124066
(Portage version: 2.1_pre9-r3)
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/files/qemu-0.8.0-stwbrx.patch15
-rw-r--r--app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild3
-rw-r--r--app-emulation/qemu-user/qemu-user-0.8.0.ebuild3
4 files changed, 25 insertions, 3 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index 7209fc833b21..c80c1ef18536 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.11 2006/04/19 19:52:21 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.12 2006/04/23 14:42:24 lu_zero Exp $
+
+ 23 Apr 2006; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.8.0-stwbrx.patch, qemu-user-0.8.0.ebuild,
+ qemu-user-0.8.0.20060329.ebuild:
+ PPC fix, thanks to dimitrij wagner <qwertyfive@gmx.net> for providing it
19 Apr 2006; Daniel Gryniewicz <dang@gentoo.org> qemu-user-0.8.0.ebuild:
Marked stable on amd64 per bug# 123972
diff --git a/app-emulation/qemu-user/files/qemu-0.8.0-stwbrx.patch b/app-emulation/qemu-user/files/qemu-0.8.0-stwbrx.patch
new file mode 100644
index 000000000000..b642702f48fc
--- /dev/null
+++ b/app-emulation/qemu-user/files/qemu-0.8.0-stwbrx.patch
@@ -0,0 +1,15 @@
+diff -Nur qemu-0.8.0-old/cpu-all.h qemu-0.8.0/cpu-all.h
+--- qemu-0.8.0-old/cpu-all.h 2006-04-21 23:45:55.000000000 +0200
++++ qemu-0.8.0/cpu-all.h 2006-04-22 00:54:14.000000000 +0200
+@@ -250,7 +250,10 @@
+ static inline void stl_le_p(void *ptr, int v)
+ {
+ #ifdef __powerpc__
+- __asm__ __volatile__ ("stwbrx %1,0,%2" : "=m" (*(uint32_t *)ptr) : "r" (v), "r" (ptr));
++ __asm__ __volatile__ ("stwbrx %0,0,%1"
++ : /* no output registers */
++ : "r" (v), "r" (ptr) /* copy v and ptr to registers */
++ : "memory"); /* memory will be clobbered*/
+ #else
+ uint8_t *p = ptr;
+ p[0] = v;
diff --git a/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild b/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild
index ea58a8057d8a..4d0d19001ac5 100644
--- a/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild
+++ b/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild,v 1.1 2006/03/29 11:17:44 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.8.0.20060329.ebuild,v 1.2 2006/04/23 14:42:24 lu_zero Exp $
inherit eutils flag-o-matic
@@ -37,6 +37,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/qemu-ppc-dirty-hack.patch
+ epatch ${FILESDIR}/qemu-0.8.0-stwbrx.patch
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile
diff --git a/app-emulation/qemu-user/qemu-user-0.8.0.ebuild b/app-emulation/qemu-user/qemu-user-0.8.0.ebuild
index 2a0f07176d9e..37f956b3d94e 100644
--- a/app-emulation/qemu-user/qemu-user-0.8.0.ebuild
+++ b/app-emulation/qemu-user/qemu-user-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.8.0.ebuild,v 1.6 2006/04/19 19:52:21 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.8.0.ebuild,v 1.7 2006/04/23 14:42:24 lu_zero Exp $
inherit eutils flag-o-matic
@@ -38,6 +38,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/qemu-ppc-dirty-hack.patch
+ epatch ${FILESDIR}/qemu-0.8.0-stwbrx.patch
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile