summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-05-29 09:45:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-05-29 09:45:15 +0000
commite0f1030669b4a1ef299c1adc3e81b8834ea96b4c (patch)
tree5053994ec7747473c431a5e8af9d4b924d173565
parentEnhance fPIC patch and fix configure options with USE=osg, bug #550130 (diff)
downloadgentoo-2-e0f1030669b4a1ef299c1adc3e81b8834ea96b4c.tar.gz
gentoo-2-e0f1030669b4a1ef299c1adc3e81b8834ea96b4c.tar.bz2
gentoo-2-e0f1030669b4a1ef299c1adc3e81b8834ea96b4c.zip
Do not pass extra-cflags/cxxflags to configure as those default to CFLAGS/CXXFLAGS respectively. Just disable optflags instead of passing complete CFLAGS to avoid forced -O3 build: This duplicated CFLAGS on the compile line and overridden important ones set by configure script; fixes bug #550554.
Signed-off-by: Alexis Ballier <aballier@gentoo.org> (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
-rw-r--r--media-video/ffmpeg/ChangeLog10
-rw-r--r--media-video/ffmpeg/ffmpeg-2.2.14.ebuild6
-rw-r--r--media-video/ffmpeg/ffmpeg-2.2.15.ebuild6
-rw-r--r--media-video/ffmpeg/ffmpeg-2.6.3.ebuild6
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
5 files changed, 17 insertions, 17 deletions
diff --git a/media-video/ffmpeg/ChangeLog b/media-video/ffmpeg/ChangeLog
index 70ab00eb749e..5e07fe60d1c8 100644
--- a/media-video/ffmpeg/ChangeLog
+++ b/media-video/ffmpeg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-video/ffmpeg
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.860 2015/05/29 09:22:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ChangeLog,v 1.861 2015/05/29 09:45:15 aballier Exp $
+
+ 29 May 2015; Alexis Ballier <aballier@gentoo.org> ffmpeg-2.2.14.ebuild,
+ ffmpeg-2.2.15.ebuild, ffmpeg-2.6.3.ebuild, ffmpeg-9999.ebuild:
+ Do not pass extra-cflags/cxxflags to configure as those default to
+ CFLAGS/CXXFLAGS respectively. Just disable optflags instead of passing
+ complete CFLAGS to avoid forced -O3 build: This duplicated CFLAGS on the
+ compile line and overridden important ones set by configure script; fixes bug
+ #550554.
29 May 2015; Alexis Ballier <aballier@gentoo.org> -ffmpeg-2.6.1.ebuild,
-ffmpeg-2.6.2.ebuild:
diff --git a/media-video/ffmpeg/ffmpeg-2.2.14.ebuild b/media-video/ffmpeg/ffmpeg-2.2.14.ebuild
index 5229921cc491..1835df9e2ded 100644
--- a/media-video/ffmpeg/ffmpeg-2.2.14.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.2.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.14.ebuild,v 1.7 2015/05/29 07:37:45 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.14.ebuild,v 1.8 2015/05/29 09:45:15 aballier Exp $
EAPI="5"
@@ -326,9 +326,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-cxxflags="${CXXFLAGS}" \
+ --optflags=" " \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"
diff --git a/media-video/ffmpeg/ffmpeg-2.2.15.ebuild b/media-video/ffmpeg/ffmpeg-2.2.15.ebuild
index d61135a71c0b..0ab0520c7f80 100644
--- a/media-video/ffmpeg/ffmpeg-2.2.15.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.2.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.15.ebuild,v 1.1 2015/04/18 10:45:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.2.15.ebuild,v 1.2 2015/05/29 09:45:15 aballier Exp $
EAPI="5"
@@ -326,9 +326,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-cxxflags="${CXXFLAGS}" \
+ --optflags=" " \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"
diff --git a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
index 48e28241a81a..db1413a40eb1 100644
--- a/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
+++ b/media-video/ffmpeg/ffmpeg-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.6.3.ebuild,v 1.1 2015/05/18 13:45:39 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-2.6.3.ebuild,v 1.2 2015/05/29 09:45:15 aballier Exp $
EAPI="5"
@@ -403,9 +403,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-cxxflags="${CXXFLAGS}" \
+ --optflags=" " \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index af52a78b8caf..ba1bf53f93df 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.189 2015/05/19 09:24:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpeg/ffmpeg-9999.ebuild,v 1.190 2015/05/29 09:45:15 aballier Exp $
EAPI="5"
@@ -403,9 +403,7 @@ multilib_src_configure() {
--cc="$(tc-getCC)" \
--cxx="$(tc-getCXX)" \
--ar="$(tc-getAR)" \
- --optflags="${CFLAGS}" \
- --extra-cflags="${CFLAGS}" \
- --extra-cxxflags="${CXXFLAGS}" \
+ --optflags=" " \
$(use_enable static-libs static) \
"${myconf[@]}"
echo "${@}"