summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-10 00:58:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-10 00:58:58 +0000
commite04d31ba674deae0e315aa210c9572061021fcbc (patch)
tree9b2895fbf467e1f7b3f8d09df1cc6368df95ca6b
parentVersion bump and remove old version. The new version simply improves on the s... (diff)
downloadgentoo-2-e04d31ba674deae0e315aa210c9572061021fcbc.tar.gz
gentoo-2-e04d31ba674deae0e315aa210c9572061021fcbc.tar.bz2
gentoo-2-e04d31ba674deae0e315aa210c9572061021fcbc.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
-rw-r--r--games-simulation/searchandrescue/ChangeLog10
-rw-r--r--games-simulation/searchandrescue/searchandrescue-0.8.3.ebuild74
2 files changed, 82 insertions, 2 deletions
diff --git a/games-simulation/searchandrescue/ChangeLog b/games-simulation/searchandrescue/ChangeLog
index 6d3442ba1cf4..4126d46d7ba7 100644
--- a/games-simulation/searchandrescue/ChangeLog
+++ b/games-simulation/searchandrescue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/searchandrescue
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.18 2009/09/04 08:24:32 tupone Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/ChangeLog,v 1.19 2010/03/10 00:58:58 mr_bones_ Exp $
+
+*searchandrescue-0.8.3 (10 Mar 2010)
+
+ 10 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +searchandrescue-0.8.3.ebuild:
+ version bump
04 Sep 2009; Tupone Alfredo <tupone@gentoo.org>
+files/searchandrescue-0.8.2-makejs.patch,
diff --git a/games-simulation/searchandrescue/searchandrescue-0.8.3.ebuild b/games-simulation/searchandrescue/searchandrescue-0.8.3.ebuild
new file mode 100644
index 000000000000..021392dc6e38
--- /dev/null
+++ b/games-simulation/searchandrescue/searchandrescue-0.8.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/searchandrescue/searchandrescue-0.8.3.ebuild,v 1.1 2010/03/10 00:58:58 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_PN=SearchAndRescue
+DESCRIPTION="Helicopter based air rescue flight simulator"
+HOMEPAGE="http://searchandrescue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/searchandrescue/${MY_PN}-${PV}.tar.gz
+ mirror://sourceforge/searchandrescue/${MY_PN}-data-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="joystick"
+
+RDEPEND="x11-libs/libXxf86vm
+ x11-libs/libXmu
+ x11-libs/libXi
+ x11-libs/libXpm
+ virtual/opengl
+ virtual/glu
+ media-libs/yiff
+ joystick? ( media-libs/libjsw )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${PN}_${PV}
+
+src_unpack() {
+ unpack ${MY_PN}-${PV}.tar.gz
+ mkdir data ; cd data
+ unpack ${MY_PN}-data-${PV}.tgz
+}
+
+src_prepare() {
+ sed -i \
+ -e 's/make /$(MAKE) /' \
+ Makefile \
+ || die "sed failed"
+ bunzip2 sar/man/${MY_PN}.6.bz2
+}
+
+src_configure() {
+ local myconf
+
+ use joystick \
+ && myconf="--enable=libjsw" \
+ || myconf="--disable=libjsw"
+
+ # NOTE: not an autoconf script
+ ./configure Linux \
+ --prefix="${GAMES_PREFIX}" \
+ ${myconf} \
+ || die
+}
+
+src_install() {
+ dogamesbin sar/${MY_PN} || die "dogamesbin failed"
+ doman sar/man/${MY_PN}.6
+ insinto /usr/share/icons/
+ doins sar/icons/*.{ico,xpm}
+ dodoc AUTHORS HACKING README
+ newicon sar/icons/SearchAndRescue.xpm ${PN}.xpm
+ cd "${WORKDIR}/data"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r * "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ make_desktop_entry SearchAndRescue "SearchAndRescue" \
+ /usr/share/pixmaps/${PN}.xpm
+ prepgamesdirs
+}