summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-04-16 19:16:38 +0000
committerTim Harder <radhermit@gentoo.org>2012-04-16 19:16:38 +0000
commitdf36551f553814a7f5ef7cce5b4dab1f5887d22f (patch)
tree45a98991bdc755c8c97095140c9b730121eb7be8
parentMarking glibc-2.14.1-r3 ppc for bug 411903 (diff)
downloadgentoo-2-df36551f553814a7f5ef7cce5b4dab1f5887d22f.tar.gz
gentoo-2-df36551f553814a7f5ef7cce5b4dab1f5887d22f.tar.bz2
gentoo-2-df36551f553814a7f5ef7cce5b4dab1f5887d22f.zip
Fix build with fltk enabled (bug #412021).
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
-rw-r--r--media-sound/csound/ChangeLog6
-rw-r--r--media-sound/csound/csound-5.17.6.ebuild3
-rw-r--r--media-sound/csound/files/csound-5.17.6-fltk.patch10
3 files changed, 17 insertions, 2 deletions
diff --git a/media-sound/csound/ChangeLog b/media-sound/csound/ChangeLog
index 342ab07ffed6..9977dafd8cd3 100644
--- a/media-sound/csound/ChangeLog
+++ b/media-sound/csound/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/csound
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.14 2012/04/11 22:32:07 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/ChangeLog,v 1.15 2012/04/16 19:16:38 radhermit Exp $
+
+ 16 Apr 2012; Tim Harder <radhermit@gentoo.org> csound-5.17.6.ebuild,
+ +files/csound-5.17.6-fltk.patch:
+ Fix build with fltk enabled (bug #412021).
*csound-5.17.2-r1 (11 Apr 2012)
diff --git a/media-sound/csound/csound-5.17.6.ebuild b/media-sound/csound/csound-5.17.6.ebuild
index 600700b23035..7239e66ddd3b 100644
--- a/media-sound/csound/csound-5.17.6.ebuild
+++ b/media-sound/csound/csound-5.17.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.6.ebuild,v 1.1 2012/04/11 22:27:42 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/csound/csound-5.17.6.ebuild,v 1.2 2012/04/16 19:16:38 radhermit Exp $
EAPI="4"
PYTHON_DEPEND="python? 2"
@@ -81,6 +81,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-5.16.6-tests.patch
+ epatch "${FILESDIR}"/${P}-fltk.patch
sed -i -e "s:^\(csoundExecutable =\).*:\1 \"${WORKDIR}/${P}_build/csound\":" \
tests/test.py || die
diff --git a/media-sound/csound/files/csound-5.17.6-fltk.patch b/media-sound/csound/files/csound-5.17.6-fltk.patch
new file mode 100644
index 000000000000..74b72689e889
--- /dev/null
+++ b/media-sound/csound/files/csound-5.17.6-fltk.patch
@@ -0,0 +1,10 @@
+--- Csound5.17.6/InOut/CMakeLists.txt
++++ Csound5.17.6/InOut/CMakeLists.txt
+@@ -148,6 +148,7 @@
+ if(USE_FLTK)
+ set(widgets_SRCS FL_graph.cpp winFLTK.c widgets.cpp)
+ make_plugin(widgets "${widgets_SRCS}" "${FLTK_LIBRARIES}")
++ include_directories(${FLTK_INCLUDE_DIR})
+ endif()
+
+ check_deps(BUILD_VIRTUAL_KEYBOARD FLTK_FOUND)