summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-06-27 14:29:45 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-06-27 14:29:45 +0000
commitddf7e0890e642d330081d6856817dee8fc6dbf27 (patch)
tree1e4f56400f3374ed2bb63d11c9a705b2a9c0b0d7
parentadded games-arcade/thinktanks-demo to p.mask in hardened/linux/amd64/no-multilib (diff)
downloadgentoo-2-ddf7e0890e642d330081d6856817dee8fc6dbf27.tar.gz
gentoo-2-ddf7e0890e642d330081d6856817dee8fc6dbf27.tar.bz2
gentoo-2-ddf7e0890e642d330081d6856817dee8fc6dbf27.zip
Updated EAPI to 5, fixed dependencies, ensured gx86-multilib support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 2B6559ED)
-rw-r--r--games-arcade/thinktanks-demo/ChangeLog10
-rw-r--r--games-arcade/thinktanks-demo/thinktanks-demo-1.1-r2.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/games-arcade/thinktanks-demo/ChangeLog b/games-arcade/thinktanks-demo/ChangeLog
index e1a690f38e80..73a905c28270 100644
--- a/games-arcade/thinktanks-demo/ChangeLog
+++ b/games-arcade/thinktanks-demo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/thinktanks-demo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/ChangeLog,v 1.10 2012/12/27 21:34:19 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/ChangeLog,v 1.11 2014/06/27 14:29:45 axs Exp $
+
+*thinktanks-demo-1.1-r2 (27 Jun 2014)
+
+ 27 Jun 2014; Ian Stakenvicius (_AxS_) <axs@gentoo.org>
+ +thinktanks-demo-1.1-r2.ebuild:
+ Updated EAPI to 5, fixed dependencies, ensured gx86-multilib support
27 Dec 2012; Tupone Alfredo <tupone@gentoo.org>
thinktanks-demo-1.1-r1.ebuild:
diff --git a/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r2.ebuild b/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r2.ebuild
new file mode 100644
index 000000000000..64832f4dd199
--- /dev/null
+++ b/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/thinktanks-demo/thinktanks-demo-1.1-r2.ebuild,v 1.1 2014/06/27 14:29:45 axs Exp $
+
+EAPI=5
+inherit unpacker games
+
+DESCRIPTION="tank combat game with lighthearted, fast paced pandemonium"
+HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=12"
+SRC_URI="ftp://ggdev-1.homelan.com/thinktanks/ThinkTanksDemo_v${PV}.sh.bin"
+
+LICENSE="THINKTANKS"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND="|| (
+ (
+ media-libs/libsdl[video,joystick,abi_x86_32(-)]
+ media-libs/libogg[abi_x86_32(-)]
+ media-libs/libvorbis[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+)"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_PREBUILT="${dir:1}/ThinkTanks.bin"
+
+src_install() {
+ dodir "${dir}" "${GAMES_BINDIR}"
+
+ tar -zxf ThinkTanks.tar.gz -C "${ED}/${dir}" || die "extracting ThinkTanks.tar.gz"
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/thinktanksdemo
+ dosym "${dir}"/thinktanksdemo "${GAMES_BINDIR}"/thinktanks-demo
+ # Using system libraries
+ rm -rf "${ED}/${dir}"/lib
+
+ insinto "${dir}"
+ doins icon.xpm
+
+ dodoc ReadMe_Linux.txt
+
+ prepgamesdirs
+}