summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-07 08:23:19 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-07 08:23:19 +0000
commitddc5af646efd58a7a27ce3a2f22affabbbdaf89d (patch)
tree1b6f362dec36526617674e06203c88937eaab95c
parentBump, see http://www.winehq.org/announce/1.5.10 for the announcement, thanks ... (diff)
downloadgentoo-2-ddc5af646efd58a7a27ce3a2f22affabbbdaf89d.tar.gz
gentoo-2-ddc5af646efd58a7a27ce3a2f22affabbbdaf89d.tar.bz2
gentoo-2-ddc5af646efd58a7a27ce3a2f22affabbbdaf89d.zip
Revision bump. Apply fix for python 3 (bug #426428, patch from Debian). Add myself as a maintainer.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--dev-lang/swig/ChangeLog9
-rw-r--r--dev-lang/swig/files/swig-2.0.7-python3.patch18
-rw-r--r--dev-lang/swig/metadata.xml5
-rw-r--r--dev-lang/swig/swig-2.0.7-r2.ebuild43
4 files changed, 73 insertions, 2 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 7abe8a41a7a8..4c35653002ca 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/swig
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.170 2012/07/12 19:22:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.171 2012/08/07 08:23:19 radhermit Exp $
+
+*swig-2.0.7-r2 (07 Aug 2012)
+
+ 07 Aug 2012; Tim Harder <radhermit@gentoo.org> +swig-2.0.7-r2.ebuild,
+ +files/swig-2.0.7-python3.patch, metadata.xml:
+ Revision bump. Apply fix for python 3 (bug #426428, patch from Debian). Add
+ myself as a maintainer.
12 Jul 2012; Tim Harder <radhermit@gentoo.org> -swig-2.0.7.ebuild:
Remove old.
diff --git a/dev-lang/swig/files/swig-2.0.7-python3.patch b/dev-lang/swig/files/swig-2.0.7-python3.patch
new file mode 100644
index 000000000000..1c7727ae2491
--- /dev/null
+++ b/dev-lang/swig/files/swig-2.0.7-python3.patch
@@ -0,0 +1,18 @@
+Description: Py3k: Map PyInt_FromSize_t to PyLong_FromSize_t
+ The latest SWIG version introduced a usage of PyInt_FromSize_t, but
+ does not define a compatibility macro for Python 3k as for the other
+ PyInt_... functions. This patch adds that macro.
+
+Author: Torsten Landschoff <torsten@debian.org>
+
+
+--- swig2.0-2.0.7.orig/Lib/python/pyhead.swg
++++ swig2.0-2.0.7/Lib/python/pyhead.swg
+@@ -5,6 +5,7 @@
+ #define PyInt_Check(x) PyLong_Check(x)
+ #define PyInt_AsLong(x) PyLong_AsLong(x)
+ #define PyInt_FromLong(x) PyLong_FromLong(x)
++#define PyInt_FromSize_t(x) PyLong_FromSize_t(x)
+ #define PyString_Check(name) PyBytes_Check(name)
+ #define PyString_FromString(x) PyUnicode_FromString(x)
+ #define PyString_Format(fmt, args) PyUnicode_Format(fmt, args)
diff --git a/dev-lang/swig/metadata.xml b/dev-lang/swig/metadata.xml
index 285b061b6535..3161255c5c1e 100644
--- a/dev-lang/swig/metadata.xml
+++ b/dev-lang/swig/metadata.xml
@@ -9,7 +9,10 @@
<maintainer>
<email>hkBst@gentoo.org</email>
</maintainer>
-
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
<longdescription lang="en">
SWIG is a software development tool that connects programs written in C and C++ with a variety of high-level programming languages. SWIG is used with different types of languages including common scripting languages such as Perl, Python, Tcl/Tk and Ruby. The list of supported languages also includes non-scripting languages such as C#, Common Lisp (Allegro CL), Java, Modula-3 and OCAML. Also several interpreted and compiled Scheme implementations (Chicken, Guile, MzScheme) are supported.
</longdescription>
diff --git a/dev-lang/swig/swig-2.0.7-r2.ebuild b/dev-lang/swig/swig-2.0.7-r2.ebuild
new file mode 100644
index 000000000000..874b4809a47b
--- /dev/null
+++ b/dev-lang/swig/swig-2.0.7-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-2.0.7-r2.ebuild,v 1.1 2012/08/07 08:23:19 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ccache doc pcre"
+RESTRICT="test"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ccache? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+DOCS=( ANNOUNCE CHANGES CHANGES.current README TODO )
+
+src_prepare() {
+ # bug 417823
+ epatch "${FILESDIR}"/${PN}-2.0.7-illegal-destructors-warning.patch
+ # bug 426428
+ epatch "${FILESDIR}"/${P}-python3.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable ccache) \
+ $(use_with pcre)
+}
+
+src_install() {
+ default
+ if use doc; then
+ dohtml -r Doc/{Devel,Manual}
+ fi
+}