summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-01 05:25:47 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-01 05:25:47 +0000
commitdd8753eec38ccb98dc6b19e2d76edbf40c38e585 (patch)
treecdef69700314950679126dd290bdb60a3799cd1d
parentwhitespace (diff)
downloadgentoo-2-dd8753eec38ccb98dc6b19e2d76edbf40c38e585.tar.gz
gentoo-2-dd8753eec38ccb98dc6b19e2d76edbf40c38e585.tar.bz2
gentoo-2-dd8753eec38ccb98dc6b19e2d76edbf40c38e585.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
-rw-r--r--sys-apps/debianutils/ChangeLog9
-rw-r--r--sys-apps/debianutils/debianutils-3.2.3.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-apps/debianutils/ChangeLog b/sys-apps/debianutils/ChangeLog
index 47f1fbf01e04..ace9da715f81 100644
--- a/sys-apps/debianutils/ChangeLog
+++ b/sys-apps/debianutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/debianutils
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.139 2009/11/16 22:47:26 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/ChangeLog,v 1.140 2010/05/01 05:25:47 jer Exp $
+
+*debianutils-3.2.3 (01 May 2010)
+
+ 01 May 2010; Jeroen Roovers <jer@gentoo.org> +debianutils-3.2.3.ebuild:
+ Version bump.
*debianutils-3.2.2 (16 Nov 2009)
diff --git a/sys-apps/debianutils/debianutils-3.2.3.ebuild b/sys-apps/debianutils/debianutils-3.2.3.ebuild
new file mode 100644
index 000000000000..f546d63fc59a
--- /dev/null
+++ b/sys-apps/debianutils/debianutils-3.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/debianutils/debianutils-3.2.3.ebuild,v 1.1 2010/05/01 05:25:47 jer Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A selection of tools from Debian"
+HOMEPAGE="http://packages.qa.debian.org/d/debianutils.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.bz2"
+
+LICENSE="BSD GPL-2 SMAIL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="kernel_linux static"
+
+PDEPEND="|| ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp sys-freebsd/freebsd-ubin )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.2.1-no-bs-namespace.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ econf || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dobin tempfile run-parts || die
+ if use kernel_linux ; then
+ dosbin installkernel || die "installkernel failed"
+ fi
+
+ into /usr
+ dosbin savelog || die "savelog failed"
+
+ doman tempfile.1 run-parts.8 savelog.8
+ use kernel_linux && doman installkernel.8
+ cd debian
+ dodoc changelog control
+}