summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-22 05:34:33 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-22 05:34:33 +0000
commitdc82db492eec7ba1b72c20030e81f820804defd4 (patch)
tree1f09f13d97f5428c88b3e6c8b92f4f755f9d3db1
parentCleanup. (diff)
downloadgentoo-2-dc82db492eec7ba1b72c20030e81f820804defd4.tar.gz
gentoo-2-dc82db492eec7ba1b72c20030e81f820804defd4.tar.bz2
gentoo-2-dc82db492eec7ba1b72c20030e81f820804defd4.zip
Version bump.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/unf/ChangeLog9
-rw-r--r--dev-ruby/unf/unf-0.1.1.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-ruby/unf/ChangeLog b/dev-ruby/unf/ChangeLog
index d3726a1261ef..c5d1668326f3 100644
--- a/dev-ruby/unf/ChangeLog
+++ b/dev-ruby/unf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/unf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.6 2012/11/25 19:17:18 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/ChangeLog,v 1.7 2013/04/22 05:34:33 graaff Exp $
+
+*unf-0.1.1 (22 Apr 2013)
+
+ 22 Apr 2013; Hans de Graaff <graaff@gentoo.org> +unf-0.1.1.ebuild:
+ Version bump.
25 Nov 2012; Thomas Kahle <tomka@gentoo.org> unf-0.0.5-r1.ebuild:
marked ~x86 per bug 432830
diff --git a/dev-ruby/unf/unf-0.1.1.ebuild b/dev-ruby/unf/unf-0.1.1.ebuild
new file mode 100644
index 000000000000..a421bd6a1d2e
--- /dev/null
+++ b/dev-ruby/unf/unf-0.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/unf/unf-0.1.1.ebuild,v 1.1 2013/04/22 05:34:33 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A wrapper library to bring Unicode Normalization Form support to Ruby/JRuby."
+HOMEPAGE="https://github.com/knu/ruby-unf"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+# jruby already has support for UNF so it does not need the extension.
+USE_RUBY=${USE_RUBY/jruby/} ruby_add_rdepend "dev-ruby/unf_ext"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/test-unit-2.5.1-r1
+ dev-ruby/shoulda
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/,/end/ d' test/helper.rb || die
+
+ # Remove development dependencies; also remove platform as we don't
+ # care about it as it is, they only use it to avoid the unf_ext dep
+ # that we tackle on our own; finally remove git ls-files usage.
+ sed -i -e '/dependency.*\(shoulda\|bundler\|jeweler\|rcov\)/d' \
+ -e '/platform/d' \
+ -e '/git ls/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ if [[ ${RUBY} == *jruby ]]; then
+ # Remove dependency over unf_ext which does not exist for JRuby
+ # remove platform, we don't set it.
+ sed -i -e '/dependency.*unf_ext/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ fi
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}