summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-01-04 23:52:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-01-04 23:52:27 +0000
commitdc4355f45c8a13fd0c10e6cd4eda38289219f921 (patch)
tree933ad2c17f08305021a639491b980d369d2fc2de
parentBumping to 1.0.1, fixes #204211 (diff)
downloadgentoo-2-dc4355f45c8a13fd0c10e6cd4eda38289219f921.tar.gz
gentoo-2-dc4355f45c8a13fd0c10e6cd4eda38289219f921.tar.bz2
gentoo-2-dc4355f45c8a13fd0c10e6cd4eda38289219f921.zip
Bump to 2.20, fixes #225143
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
-rw-r--r--app-forensics/autopsy/ChangeLog9
-rw-r--r--app-forensics/autopsy/autopsy-2.20.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/app-forensics/autopsy/ChangeLog b/app-forensics/autopsy/ChangeLog
index bcd87e38f742..ada2840d5077 100644
--- a/app-forensics/autopsy/ChangeLog
+++ b/app-forensics/autopsy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/autopsy
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.12 2007/02/05 21:06:47 dragonheart Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/ChangeLog,v 1.13 2009/01/04 23:52:27 patrick Exp $
+
+*autopsy-2.20 (04 Jan 2009)
+
+ 04 Jan 2009; Patrick Lauer <patrick@gentoo.org> +autopsy-2.20.ebuild:
+ Bump to 2.20, fixes #225143
*autopsy-2.08 (05 Feb 2007)
diff --git a/app-forensics/autopsy/autopsy-2.20.ebuild b/app-forensics/autopsy/autopsy-2.20.ebuild
new file mode 100644
index 000000000000..9f01958bf85d
--- /dev/null
+++ b/app-forensics/autopsy/autopsy-2.20.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/autopsy/autopsy-2.20.ebuild,v 1.1 2009/01/04 23:52:27 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
+HOMEPAGE="http://www.sleuthkit.org/autopsy/"
+SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+# Runtime depend on grep and file deliberate
+RDEPEND=">=dev-lang/perl-5.8.0
+ >=app-forensics/sleuthkit-3.0.0
+ sys-apps/grep
+ sys-apps/file"
+DEPEND=""
+
+src_compile() {
+ ./configure 2>&1 >/dev/null << EOF
+n
+/tmp
+EOF
+
+ echo "#!/usr/bin/perl -wT" > autopsy
+ echo "use lib '/usr/lib/autopsy/';" >> autopsy
+ echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
+ cat base/autopsy.base >> autopsy
+
+ sed -i 's:conf.pl:/etc/autopsy.pl:' $(grep -lr conf\.pl ./)
+ sed -i "s:INSTALLDIR = .*:INSTALLDIR = \'/usr/lib/autopsy\';:" conf.pl
+}
+
+src_install() {
+ insinto /usr/lib/autopsy
+ doins autopsy
+ doins global.css
+ insinto /usr/lib/autopsy/help
+ doins help/*
+ insinto /usr/lib/autopsy/lib
+ doins lib/*
+ insinto /usr/lib/autopsy/pict
+ doins pict/*
+ insinto /etc
+ newins conf.pl autopsy.pl
+
+ dodir /usr/bin
+ dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
+ fperms +x /usr/lib/autopsy/autopsy
+
+ doman $(find man/ -type f)
+ dodoc CHANGES.txt README* TODO.txt docs/sleuthkit-informer*.txt
+}