summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-03 16:00:27 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-03 16:00:27 +0000
commitdbe0f7bd0a1913696470b73819caf19aa53356c9 (patch)
treec4e1e45bed1535f2d08ccf28647dbb47a459c859
parentMarking gcc-4.5.3-r2 ppc64 for bug 402847 (diff)
downloadgentoo-2-dbe0f7bd0a1913696470b73819caf19aa53356c9.tar.gz
gentoo-2-dbe0f7bd0a1913696470b73819caf19aa53356c9.tar.bz2
gentoo-2-dbe0f7bd0a1913696470b73819caf19aa53356c9.zip
Fix overflow, bug 339451 by Kevin McCarthy.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
-rw-r--r--app-misc/rioutil/ChangeLog10
-rw-r--r--app-misc/rioutil/files/rioutil-1.5.0-buffer-overflow.patch15
-rw-r--r--app-misc/rioutil/rioutil-1.5.0-r2.ebuild35
3 files changed, 58 insertions, 2 deletions
diff --git a/app-misc/rioutil/ChangeLog b/app-misc/rioutil/ChangeLog
index 53d8813c7c18..e2c6832f541f 100644
--- a/app-misc/rioutil/ChangeLog
+++ b/app-misc/rioutil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/rioutil
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/ChangeLog,v 1.28 2011/03/20 18:23:42 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/ChangeLog,v 1.29 2012/03/03 16:00:27 pacho Exp $
+
+*rioutil-1.5.0-r2 (03 Mar 2012)
+
+ 03 Mar 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/rioutil-1.5.0-buffer-overflow.patch, +rioutil-1.5.0-r2.ebuild:
+ Fix overflow, bug 339451 by Kevin McCarthy.
20 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> rioutil-1.5.0-r1.ebuild:
Fix libusb depend to correct SLOT and install udev rules to /lib/udev instead
diff --git a/app-misc/rioutil/files/rioutil-1.5.0-buffer-overflow.patch b/app-misc/rioutil/files/rioutil-1.5.0-buffer-overflow.patch
new file mode 100644
index 000000000000..1739a146c485
--- /dev/null
+++ b/app-misc/rioutil/files/rioutil-1.5.0-buffer-overflow.patch
@@ -0,0 +1,15 @@
+flist->genre is defined as 'char genre[17]' so don't copy 22 into it
+
+Patch by Kevin McCarthy <signals42@gmail.com>
+
+--- librioutil/file_list.c
++++ librioutil/file_list.c
+@@ -241,7 +241,7 @@
+ strncpy(flist->title, info.data->title, 64);
+ strncpy(flist->album, info.data->album, 64);
+ strncpy(flist->name, info.data->name, 64);
+- strncpy(flist->genre, (char *)info.data->genre2, 22);
++ strncpy(flist->genre, (char *)info.data->genre2, 17);
+
+ strncpy(flist->year, (char *)info.data->year2, 4);
+
diff --git a/app-misc/rioutil/rioutil-1.5.0-r2.ebuild b/app-misc/rioutil/rioutil-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..80963fe16ecf
--- /dev/null
+++ b/app-misc/rioutil/rioutil-1.5.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rioutil/rioutil-1.5.0-r2.ebuild,v 1.1 2012/03/03 16:00:26 pacho Exp $
+
+EAPI=4
+inherit multilib eutils
+
+DESCRIPTION="Command line tool for transfering mp3s to and from a Rio 600, 800, Rio Riot, and Nike PSA/Play"
+HOMEPAGE="http://rioutil.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rioutil/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libusb:0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-buffer-overflow.patch"
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="/usr/$(get_libdir)" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ insinto /$(get_libdir)/udev/rules.d
+ doins "${FILESDIR}"/75-rio.rules
+}