summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-07 21:25:52 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-07 21:25:52 +0000
commitdb6cde1c03d1c457b8679dcd1fdedd6070f57ef0 (patch)
treecc4444cafc87f07e693368e4c8ecef3055c4e01c
parentAdd new alsa-lib version-r1 to IUSE_PCM_PLUGIN masking (diff)
downloadgentoo-2-db6cde1c03d1c457b8679dcd1fdedd6070f57ef0.tar.gz
gentoo-2-db6cde1c03d1c457b8679dcd1fdedd6070f57ef0.tar.bz2
gentoo-2-db6cde1c03d1c457b8679dcd1fdedd6070f57ef0.zip
version bump
(Portage version: 2.1.2.7)
-rw-r--r--media-libs/alsa-lib/ChangeLog9
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc4-r1.ebuild83
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc4.ebuild70
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc43
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4-r13
5 files changed, 167 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index f6624d2a379d..213648ead1f1 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.230 2007/05/01 09:32:14 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.231 2007/05/07 21:25:52 genstef Exp $
+
+*alsa-lib-1.0.14_rc4-r1 (07 May 2007)
+*alsa-lib-1.0.14_rc4 (07 May 2007)
+
+ 07 May 2007; Stefan Schweizer <genstef@gentoo.org>
+ +alsa-lib-1.0.14_rc4.ebuild, +alsa-lib-1.0.14_rc4-r1.ebuild:
+ version bump
01 May 2007; Markus Rothe <corsair@gentoo.org> alsa-lib-1.0.14_rc2.ebuild:
Stable on ppc64; bug #175141
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc4-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc4-r1.ebuild
new file mode 100644
index 000000000000..c01bd7a03354
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc4-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc4-r1.ebuild,v 1.1 2007/05/07 21:25:52 genstef Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND=">=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ "--with-pcm-plugins=${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try media-sound/alsa-driver before filing bugs about unstable"
+ elog "or missing output with in-kernel drivers. Misaligned versions of"
+ elog "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc4.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc4.ebuild
new file mode 100644
index 000000000000..53ff5f53e44a
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc4.ebuild,v 1.1 2007/05/07 21:25:52 genstef Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug"
+
+RDEPEND=">=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with debug) \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try media-sound/alsa-driver before filing bugs about unstable"
+ elog "or missing output with in-kernel drivers. Misaligned versions of"
+ elog "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4
new file mode 100644
index 000000000000..ae045b3e8338
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4
@@ -0,0 +1,3 @@
+MD5 1c96a1e36270bc22df0a85f74df64290 alsa-lib-1.0.14rc4.tar.bz2 784451
+RMD160 67f07d7deb44ca9545c34dc3f66b069b9b72eb13 alsa-lib-1.0.14rc4.tar.bz2 784451
+SHA256 e55912c5fa5b28f91138710aa29bfa5e982a0b707c9cf7bfc8612b60f6b95f17 alsa-lib-1.0.14rc4.tar.bz2 784451
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4-r1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4-r1
new file mode 100644
index 000000000000..ae045b3e8338
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc4-r1
@@ -0,0 +1,3 @@
+MD5 1c96a1e36270bc22df0a85f74df64290 alsa-lib-1.0.14rc4.tar.bz2 784451
+RMD160 67f07d7deb44ca9545c34dc3f66b069b9b72eb13 alsa-lib-1.0.14rc4.tar.bz2 784451
+SHA256 e55912c5fa5b28f91138710aa29bfa5e982a0b707c9cf7bfc8612b60f6b95f17 alsa-lib-1.0.14rc4.tar.bz2 784451