summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-22 06:13:57 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-22 06:13:57 +0000
commitdb30a5f9e3def70382df09ca51deb1ff13147990 (patch)
tree233f1dfe7c5b85cce61c695aa5cf859ccc199732
parentVersion bump #251651 by Lars (Polynomial-C). (diff)
downloadgentoo-2-db30a5f9e3def70382df09ca51deb1ff13147990.tar.gz
gentoo-2-db30a5f9e3def70382df09ca51deb1ff13147990.tar.bz2
gentoo-2-db30a5f9e3def70382df09ca51deb1ff13147990.zip
Fix building with gcc-4.3 #251684 by Diego E. Pettenò.
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.8 x86_64)
-rw-r--r--sys-fs/autorun/ChangeLog8
-rw-r--r--sys-fs/autorun/autorun-3.17.ebuild12
-rw-r--r--sys-fs/autorun/files/autorun-3.17-headers.patch13
3 files changed, 28 insertions, 5 deletions
diff --git a/sys-fs/autorun/ChangeLog b/sys-fs/autorun/ChangeLog
index 7e881d95a0b5..bff1bab37af1 100644
--- a/sys-fs/autorun/ChangeLog
+++ b/sys-fs/autorun/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/autorun
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/autorun/ChangeLog,v 1.3 2006/09/02 01:12:50 vapier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/autorun/ChangeLog,v 1.4 2008/12/22 06:13:57 vapier Exp $
+
+ 22 Dec 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/autorun-3.17-headers.patch, autorun-3.17.ebuild:
+ Fix building with gcc-4.3 #251684 by Diego E. Pettenò.
*autorun-3.17 (02 Sep 2006)
diff --git a/sys-fs/autorun/autorun-3.17.ebuild b/sys-fs/autorun/autorun-3.17.ebuild
index c49e99208b77..c94a6232fe3f 100644
--- a/sys-fs/autorun/autorun-3.17.ebuild
+++ b/sys-fs/autorun/autorun-3.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/autorun/autorun-3.17.ebuild,v 1.2 2006/09/05 07:11:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/autorun/autorun-3.17.ebuild,v 1.3 2008/12/22 06:13:57 vapier Exp $
inherit kde-functions eutils
@@ -19,7 +19,13 @@ DEPEND="app-text/xmlto
=app-text/docbook-xml-dtd-4.1.2*"
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-headers.patch #251684
+}
+
src_install() {
- make install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}" || die
dodoc AUTHORS ChangeLog NEWS README
}
diff --git a/sys-fs/autorun/files/autorun-3.17-headers.patch b/sys-fs/autorun/files/autorun-3.17-headers.patch
new file mode 100644
index 000000000000..642f1596b704
--- /dev/null
+++ b/sys-fs/autorun/files/autorun-3.17-headers.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/251684
+
+--- autorun.cc
++++ autorun.cc
+@@ -90,6 +90,8 @@ char *strchr (), *strrchr ();
+
+ #include <errno.h>
+
++#include <stdlib.h>
++
+ #ifndef MNTTYPE_ISO9660
+ #define MNTTYPE_ISO9660 "iso9660"
+ #endif