summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-22 17:04:17 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-22 17:04:17 +0000
commitd8bc6676698502b02eb07e4919a839d69a9e978f (patch)
tree02fd298272e023c49c2c2f796e0f0ab3c139c928
parentfix a typo, spotted by Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmai... (diff)
downloadgentoo-2-d8bc6676698502b02eb07e4919a839d69a9e978f.tar.gz
gentoo-2-d8bc6676698502b02eb07e4919a839d69a9e978f.tar.bz2
gentoo-2-d8bc6676698502b02eb07e4919a839d69a9e978f.zip
New eclass stuff
(Portage version: 2.1.3.16)
-rw-r--r--x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild b/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
index 87f488ad783e..85e7e12a3b5b 100644
--- a/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
+++ b/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild,v 1.1 2007/12/21 19:04:14 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.4.0_rc1.ebuild,v 1.2 2007/12/22 17:04:17 caleb Exp $
inherit qt4-build
@@ -28,6 +28,8 @@ RDEPEND="~x11-libs/qt-core-${PV}
DEPEND="${RDEPEND}"
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+
src_unpack() {
qt4-build_src_unpack
@@ -58,13 +60,6 @@ src_compile() {
echo ./configure ${myconf}
./configure ${myconf} || die
- build_directories src/sql src/plugins/sqldrivers
-
+ build_target_directories
}
-src_install() {
-
- install_directories src/sql src/plugins/sqldrivers
-
- fix_library_files
-}