summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-01-26 11:12:45 +0000
committerMichael Januszewski <spock@gentoo.org>2004-01-26 11:12:45 +0000
commitd7d161c6cdae142d2b0f781b5c141a65855a8c76 (patch)
tree9198504b36fd32047a8c92c6ea47e2f14774417e
parentversion bump (diff)
downloadgentoo-2-d7d161c6cdae142d2b0f781b5c141a65855a8c76.tar.gz
gentoo-2-d7d161c6cdae142d2b0f781b5c141a65855a8c76.tar.bz2
gentoo-2-d7d161c6cdae142d2b0f781b5c141a65855a8c76.zip
Version bump.
-rw-r--r--sys-kernel/vanilla-prepatch-sources/ChangeLog10
-rw-r--r--sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre72
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre7.ebuild47
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/ChangeLog b/sys-kernel/vanilla-prepatch-sources/ChangeLog
index 8d7dfc90c157..b1274a7c8739 100644
--- a/sys-kernel/vanilla-prepatch-sources/ChangeLog
+++ b/sys-kernel/vanilla-prepatch-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/vanilla-prepatch-sources
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.23 2004/01/07 16:07:17 plasmaroo Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.24 2004/01/26 11:12:45 spock Exp $
+
+*vanilla-prepatch-sources-2.4.25_pre7 (26 Jan 2004)
+
+ 26 Jan 2004; Michal 'Spock' Januszewski <spock@gentoo.org>
+ vanilla-prepatch-sources-2.4.25_pre7.ebuild:
+ Bumped.
*vanilla-prepatch-sources-2.4.25_pre4 (07 Jan 2004)
diff --git a/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre7 b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre7
new file mode 100644
index 000000000000..d4e9e6894f5b
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.25_pre7
@@ -0,0 +1,2 @@
+MD5 1e055c42921b2396a559d84df4c3d9aa linux-2.4.24.tar.bz2 29837818
+MD5 c43e058204fac051318a8e7844b38605 patch-2.4.25-pre7.bz2 1722306
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre7.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre7.ebuild
new file mode 100644
index 000000000000..7bcf5436244d
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.25_pre7.ebuild,v 1.1 2004/01/26 11:12:45 spock Exp $
+
+IUSE="build"
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version.
+
+OKV=2.4.24
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+# We'll see how not mirroring kernels goes over with the mirrors
+restrict="nomirror"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "Failed to apply patch!"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}