summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-10-16 17:48:16 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-10-16 17:48:16 +0000
commitd79002015942fbc8bb0da056ac8d3262afbeab73 (patch)
treeca5d96c17f6370bdabd309cb976e5829dd6f6bf7
parentAdded ~ppc64; bug #149658 (diff)
downloadgentoo-2-d79002015942fbc8bb0da056ac8d3262afbeab73.tar.gz
gentoo-2-d79002015942fbc8bb0da056ac8d3262afbeab73.tar.bz2
gentoo-2-d79002015942fbc8bb0da056ac8d3262afbeab73.zip
Handle no kernel sources with eerror instead of die, thanks to Chris Gianelloni <wolf31o2@gentoo.org> in bug 129811
(Portage version: 2.1.2_pre3-r2)
-rw-r--r--sys-apps/hal/ChangeLog7
-rw-r--r--sys-apps/hal/hal-0.5.7-r3.ebuild6
-rw-r--r--sys-apps/hal/hal-0.5.7.1-r1.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 761987b16354..2f62c4692002 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.105 2006/09/22 00:22:52 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.106 2006/10/16 17:48:16 genstef Exp $
+
+ 16 Oct 2006; Stefan Schweizer <genstef@gentoo.org> hal-0.5.7-r3.ebuild,
+ -hal-0.5.7.1.ebuild, hal-0.5.7.1-r1.ebuild:
+ Handle no kernel sources with eerror instead of die, thanks to Chris
+ Gianelloni <wolf31o2@gentoo.org> in bug 129811
22 Sep 2006; Doug Goldstein <cardoe@gentoo.org>
-files/hal-0.4.1-old_storage_policy.patch,
diff --git a/sys-apps/hal/hal-0.5.7-r3.ebuild b/sys-apps/hal/hal-0.5.7-r3.ebuild
index e8c004c566fa..2dac3006a419 100644
--- a/sys-apps/hal/hal-0.5.7-r3.ebuild
+++ b/sys-apps/hal/hal-0.5.7-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.7-r3.ebuild,v 1.10 2006/08/29 04:20:49 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.7-r3.ebuild,v 1.11 2006/10/16 17:48:16 genstef Exp $
inherit eutils linux-info debug
@@ -64,9 +64,9 @@ function notify_procfs() {
}
pkg_setup() {
- linux-info_pkg_setup
+ get_version || eerror "Unable to calculate Linux Kernel version"
- kernel_is ge 2 6 15 || die "HAL requires a kernel version 2.6.15 or newer"
+ kernel_is ge 2 6 15 || eerror "HAL requires a kernel version 2.6.15 or newer"
if kernel_is lt 2 6 16 ; then
linux_chkconfig_present KOBJECT_UEVENT || notify_uevent
diff --git a/sys-apps/hal/hal-0.5.7.1-r1.ebuild b/sys-apps/hal/hal-0.5.7.1-r1.ebuild
index 8d443d0ec8fd..5515c76184f1 100644
--- a/sys-apps/hal/hal-0.5.7.1-r1.ebuild
+++ b/sys-apps/hal/hal-0.5.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.7.1-r1.ebuild,v 1.3 2006/09/17 20:48:15 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.7.1-r1.ebuild,v 1.4 2006/10/16 17:48:16 genstef Exp $
inherit eutils linux-info debug
@@ -65,9 +65,9 @@ function notify_procfs() {
}
pkg_setup() {
- linux-info_pkg_setup
+ get_version || eerror "Unable to calculate Linux Kernel version"
- kernel_is ge 2 6 15 || die "HAL requires a kernel version 2.6.15 or newer"
+ kernel_is ge 2 6 15 || eerror "HAL requires a kernel version 2.6.15 or newer"
if kernel_is lt 2 6 16 ; then
linux_chkconfig_present KOBJECT_UEVENT || notify_uevent