summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephanie J. Lockwood-Childs <wormo@gentoo.org>2009-07-28 05:23:26 +0000
committerStephanie J. Lockwood-Childs <wormo@gentoo.org>2009-07-28 05:23:26 +0000
commitd639af3eee9fa12c1df6ac36966c68133c25c618 (patch)
tree7d61a53fa43016a445c65294d0273fa53e3b78cd
parentVersion bump (bug #276854). (diff)
downloadgentoo-2-d639af3eee9fa12c1df6ac36966c68133c25c618.tar.gz
gentoo-2-d639af3eee9fa12c1df6ac36966c68133c25c618.tar.bz2
gentoo-2-d639af3eee9fa12c1df6ac36966c68133c25c618.zip
Move patch for CVE-2008-4690 to lynx-2.8.6-r4 so it can be tested by arch
teams before stabling (Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--www-client/lynx/ChangeLog9
-rw-r--r--www-client/lynx/lynx-2.8.6-r2.ebuild8
-rw-r--r--www-client/lynx/lynx-2.8.6-r4.ebuild87
3 files changed, 96 insertions, 8 deletions
diff --git a/www-client/lynx/ChangeLog b/www-client/lynx/ChangeLog
index 4f98d5a38545..74c7b1b2672c 100644
--- a/www-client/lynx/ChangeLog
+++ b/www-client/lynx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-client/lynx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.81 2009/07/26 23:07:42 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/ChangeLog,v 1.82 2009/07/28 05:23:26 wormo Exp $
+
+*lynx-2.8.6-r4 (28 Jul 2009)
+
+ 28 Jul 2009; Stephanie Lockwood-Childs <wormo@gentoo.org>
+ lynx-2.8.6-r2.ebuild, +lynx-2.8.6-r4.ebuild:
+ Move patch for CVE-2008-4690 to lynx-2.8.6-r4 so it can be tested by arch
+ teams before stabling
*lynx-2.8.7_p1 (26 Jul 2009)
diff --git a/www-client/lynx/lynx-2.8.6-r2.ebuild b/www-client/lynx/lynx-2.8.6-r2.ebuild
index 88d0ec6913fa..defd5676f2a2 100644
--- a/www-client/lynx/lynx-2.8.6-r2.ebuild
+++ b/www-client/lynx/lynx-2.8.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.6-r2.ebuild,v 1.16 2009/07/26 05:55:24 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.6-r2.ebuild,v 1.17 2009/07/28 05:23:26 wormo Exp $
inherit eutils
@@ -40,12 +40,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-CVE-2008-4690.patch"
-}
-
src_compile() {
local myconf
use unicode && myconf="--with-screen=ncursesw"
diff --git a/www-client/lynx/lynx-2.8.6-r4.ebuild b/www-client/lynx/lynx-2.8.6-r4.ebuild
new file mode 100644
index 000000000000..ed06392355fb
--- /dev/null
+++ b/www-client/lynx/lynx-2.8.6-r4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/lynx/lynx-2.8.6-r4.ebuild,v 1.1 2009/07/28 05:23:26 wormo Exp $
+
+inherit eutils
+
+MY_P=${PN}${PV}
+S=${WORKDIR}/${MY_P//./-}
+
+DESCRIPTION="An excellent console-based web browser with ssl support"
+HOMEPAGE="http://lynx.isc.org/"
+SRC_URI="ftp://lynx.isc.org/${MY_P}/${MY_P}rel.4.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 cjk ipv6 nls ssl unicode"
+
+RDEPEND="sys-libs/ncurses
+ sys-libs/zlib
+ nls? ( virtual/libintl )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ bzip2? ( app-arch/bzip2 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+LANGS="ca cs da de et fr hu it ja nl pt_BR ru rw sl sv tr uk vi zh_CN zh_TW"
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ eerror "Installing lynx with the unicode flag requires ncurses be"
+ eerror "built with it as well. Please make sure your /etc/make.conf"
+ eerror "or /etc/portage/package.use enables it, and re-install"
+ eerror "ncurses with \`emerge --oneshot sys-libs/ncurses\`."
+ die "Re-emerge ncurses with the unicode flag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-CVE-2008-4690.patch"
+}
+
+src_compile() {
+ local myconf
+ use unicode && myconf="--with-screen=ncursesw"
+
+ econf \
+ --enable-cgi-links \
+ --enable-persistent-cookies \
+ --enable-prettysrc \
+ --enable-nsl-fork \
+ --enable-file-upload \
+ --enable-read-eta \
+ --enable-color-style \
+ --enable-scrollbar \
+ --enable-included-msgs \
+ --with-zlib \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_enable cjk) \
+ $(use_enable linguas_ja japanese-utf8) \
+ $(use_with ssl) \
+ $(use_with bzip2 bzlib) \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dosed "s|^HELPFILE.*$|HELPFILE:file://localhost/usr/share/doc/${PF}/lynx_help/lynx_help_main.html|" \
+ /etc/lynx.cfg
+ dodoc CHANGES COPYHEADER PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ dohtml -r lynx_help/*
+}