summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-11-23 17:32:57 +0000
committerUlrich Müller <ulm@gentoo.org>2011-11-23 17:32:57 +0000
commitd554cbc2a5076e40a35a0572d9c2f82c38b7c8ea (patch)
treec32af9cbc74b1316d1f5f391a37adac13b448d54
parent[bump] virtual/perl-IO-Compress-2.43.0 (diff)
downloadgentoo-2-d554cbc2a5076e40a35a0572d9c2f82c38b7c8ea.tar.gz
gentoo-2-d554cbc2a5076e40a35a0572d9c2f82c38b7c8ea.tar.bz2
gentoo-2-d554cbc2a5076e40a35a0572d9c2f82c38b7c8ea.zip
Define obsolete variables properly, in order to prevent a crash with dev-python/ipython. Fixes bug 391403.
(Portage version: 2.1.10.37/cvs/Linux x86_64)
-rw-r--r--app-emacs/python-mode/ChangeLog9
-rw-r--r--app-emacs/python-mode/files/python-mode-6.0.3-obsolete-vars.patch21
-rw-r--r--app-emacs/python-mode/python-mode-6.0.3-r1.ebuild (renamed from app-emacs/python-mode/python-mode-6.0.3.ebuild)4
3 files changed, 32 insertions, 2 deletions
diff --git a/app-emacs/python-mode/ChangeLog b/app-emacs/python-mode/ChangeLog
index 4b3de490b7f5..f64533d7d4f8 100644
--- a/app-emacs/python-mode/ChangeLog
+++ b/app-emacs/python-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/python-mode
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.51 2011/11/21 18:01:23 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/ChangeLog,v 1.52 2011/11/23 17:32:56 ulm Exp $
+
+*python-mode-6.0.3-r1 (23 Nov 2011)
+
+ 23 Nov 2011; Ulrich Mueller <ulm@gentoo.org> -python-mode-6.0.3.ebuild,
+ +python-mode-6.0.3-r1.ebuild, +files/python-mode-6.0.3-obsolete-vars.patch:
+ Define obsolete variables properly, in order to prevent a crash with
+ dev-python/ipython. Fixes bug 391403.
*python-mode-6.0.3 (21 Nov 2011)
diff --git a/app-emacs/python-mode/files/python-mode-6.0.3-obsolete-vars.patch b/app-emacs/python-mode/files/python-mode-6.0.3-obsolete-vars.patch
new file mode 100644
index 000000000000..cd08f9720d9b
--- /dev/null
+++ b/app-emacs/python-mode/files/python-mode-6.0.3-obsolete-vars.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/391403
+
+--- python-mode.el-6.0.3-orig/python-mode.el
++++ python-mode.el-6.0.3/python-mode.el
+@@ -163,11 +163,11 @@
+ ;; Execute stuff start
+
+ ;; backward compatibility
+-(defalias 'py-python-command 'py-shell-name)
+-(defalias 'py-jpython-command 'py-shell-name)
+-(defalias 'py-jython-command 'py-shell-name)
+-(defalias 'py-default-interpreter 'py-shell-name)
+-(defalias 'python-command 'py-shell-name)
++(defvaralias 'py-python-command 'py-shell-name)
++(defvaralias 'py-jpython-command 'py-shell-name)
++(defvaralias 'py-jython-command 'py-shell-name)
++(defvaralias 'py-default-interpreter 'py-shell-name)
++(defvaralias 'python-command 'py-shell-name)
+
+ (defcustom py-encoding-string " # -*- coding: utf-8 -*-"
+ "Default string specifying encoding in the heading of file. "
diff --git a/app-emacs/python-mode/python-mode-6.0.3.ebuild b/app-emacs/python-mode/python-mode-6.0.3-r1.ebuild
index 90da1a6150ff..ee9ff9782a64 100644
--- a/app-emacs/python-mode/python-mode-6.0.3.ebuild
+++ b/app-emacs/python-mode/python-mode-6.0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.0.3.ebuild,v 1.1 2011/11/21 18:01:23 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/python-mode/python-mode-6.0.3-r1.ebuild,v 1.1 2011/11/23 17:32:56 ulm Exp $
EAPI=4
@@ -17,10 +17,12 @@ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-free
IUSE=""
S="${WORKDIR}/${MY_P}"
+ELISP_PATCHES="${P}-obsolete-vars.patch"
SITEFILE="50${PN}-gentoo.el"
DOCS="NEWS"
src_prepare() {
+ elisp_src_prepare
# remove XEmacs specific file
rm highlight-indentation.el || die
}