summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-12-01 19:39:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-12-01 19:39:09 +0000
commitd507090c7859a4dceafc36319f4e2138bbba1941 (patch)
tree8e165d48473e46d6a81be068212dc7bf5b012b97
parentcleanup; fixed #315405 (diff)
downloadgentoo-2-d507090c7859a4dceafc36319f4e2138bbba1941.tar.gz
gentoo-2-d507090c7859a4dceafc36319f4e2138bbba1941.tar.bz2
gentoo-2-d507090c7859a4dceafc36319f4e2138bbba1941.zip
Quick version bump to add the beta to ~arch for python-2.7 support, mainly. (bug 333001).
(Portage version: 2.1.9.25/cvs/Linux x86_64)
-rw-r--r--net-misc/wicd/ChangeLog8
-rw-r--r--net-misc/wicd/wicd-1.7.1_beta2.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index e0156ea4c7d7..c2040903a3a0 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.72 2010/05/23 19:27:04 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.73 2010/12/01 19:39:09 darkside Exp $
+
+*wicd-1.7.1_beta2 (01 Dec 2010)
+
+ 01 Dec 2010; Jeremy Olexa <darkside@gentoo.org> +wicd-1.7.1_beta2.ebuild:
+ Quick version bump to add the beta to ~arch for python-2.7 support,
+ mainly. (bug 333001).
23 May 2010; Jeremy Olexa <darkside@gentoo.org> wicd-1.7.0.ebuild:
Bump urwid dependency, bug 310621
diff --git a/net-misc/wicd/wicd-1.7.1_beta2.ebuild b/net-misc/wicd/wicd-1.7.1_beta2.ebuild
new file mode 100644
index 000000000000..8142813078ec
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.1_beta2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.1_beta2.ebuild,v 1.1 2010/12/01 19:39:09 darkside Exp $
+
+EAPI=2
+
+inherit eutils distutils
+
+MY_P=${P/_beta/b}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="http://downloads.wicd.net/src/testing/1.7.x/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X +gtk ioctl libnotify ncurses nls +pm-utils"
+
+DEPEND=""
+# Maybe virtual/dhcp would work, but there are enough problems with
+# net-misc/dhcp that I want net-misc/dhcpcd to be guarenteed to be considered
+# first if none are installed.
+RDEPEND="
+ dev-python/dbus-python
+ X? ( gtk? ( dev-python/pygtk
+ || (
+ x11-misc/ktsuss
+ x11-libs/gksu
+ kde-base/kdesu
+ )
+ )
+ )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ !gtk? ( dev-python/pygobject )
+ ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
+ libnotify? ( dev-python/notify-python )
+ ncurses? ( >=dev-python/urwid-0.9.9.1 )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
+ "
+
+src_compile() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ ${python} ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="CHANGES NEWS AUTHORS README"
+ distutils_src_install
+ keepdir /var/lib/wicd/configurations \
+ || die "keepdir failed, critical for this app"
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect} \
+ || die "keepdir failed, critical for this app"
+ keepdir /var/log/wicd \
+ || die "keepdir failed, critical for this app"
+ use nls || rm -rf "${D}"/usr/share/locale
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/conf.d/rc"
+ elog "(For example, RC_PLUG_SERVICES=\"!net.eth0 !net.wlan0\")"
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if ! has_version sys-auth/pambase[consolekit]; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+}