summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-30 19:00:57 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-30 19:00:57 +0000
commitd4c6d7969dbca2d96702e6d985f9a50e6a71adec (patch)
tree7eb5fd5aeb72666e6dc18e19bd02a26d78e29893
parentVersion bumped. (diff)
downloadgentoo-2-d4c6d7969dbca2d96702e6d985f9a50e6a71adec.tar.gz
gentoo-2-d4c6d7969dbca2d96702e6d985f9a50e6a71adec.tar.bz2
gentoo-2-d4c6d7969dbca2d96702e6d985f9a50e6a71adec.zip
old
(Portage version: 2.2_pre5)
-rw-r--r--sys-libs/libtermcap-compat/files/libtermcap-compat-2.0.8-fPIC.patch29
-rw-r--r--sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch14
-rw-r--r--sys-libs/libtermcap-compat/libtermcap-compat-2.0.8-r1.ebuild65
3 files changed, 0 insertions, 108 deletions
diff --git a/sys-libs/libtermcap-compat/files/libtermcap-compat-2.0.8-fPIC.patch b/sys-libs/libtermcap-compat/files/libtermcap-compat-2.0.8-fPIC.patch
deleted file mode 100644
index 19929cf72a98..000000000000
--- a/sys-libs/libtermcap-compat/files/libtermcap-compat-2.0.8-fPIC.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile 2004-03-17 17:24:04.281593999 +0000
-+++ Makefile 2004-03-17 17:24:57.764781342 +0000
-@@ -28,23 +28,18 @@
- prefix=/
-
- .c.o:
-- $(CC) $(CFLAGS) -c $<
-- $(CC) $(CFLAGS) -fPIC -c $< -o pic/$@
-+ $(CC) $(CFLAGS) -fPIC -c $< -o $@
-
- SRCS = termcap.c tparam.c version.c
- OBJS= $(SRCS:.c=.o)
-
--all lib: pic .depend $(TARGETS) info
-+all lib: .depend $(TARGETS) info
-
- $(STATIC_LIB): $(OBJS)
- $(AR) $(ARFLAGS) $@ $(OBJS)
-
- $(SHARED_LIB): $(OBJS)
-- cd pic; \
-- $(CC) -shared -o ../$@ -Wl,-soname,$(SONAME_SHARED_LIB) $(OBJS) -lc
--
--pic:
-- -if [ ! -d pic ]; then mkdir pic; fi
-+ $(CC) -shared -o $@ -Wl,-soname,$(SONAME_SHARED_LIB) $(OBJS) -lc
-
- install: lib install-dirs install-data
- -if [ -f $(prefix)/lib/$(SHARED_LIB) ]; then \
diff --git a/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch b/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch
deleted file mode 100644
index 350659745d07..000000000000
--- a/sys-libs/libtermcap-compat/files/libtermcap-compat_bcopy_fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- tparam.c.orig Sun Feb 15 22:40:15 1998
-+++ tparam.c Thu Sep 5 08:16:58 2002
-@@ -24,9 +24,11 @@
- #undef STDC_HEADERS
- #define STDC_HEADERS
- #define HAVE_UNISTD_H
-+/*
- #if defined(HAVE_STRING_H) || defined(STDC_HEADERS)
- #define bcopy(s, d, n) memcpy ((d), (s), (n))
- #endif
-+ */
- #endif
-
- #ifdef STDC_HEADERS
diff --git a/sys-libs/libtermcap-compat/libtermcap-compat-2.0.8-r1.ebuild b/sys-libs/libtermcap-compat/libtermcap-compat-2.0.8-r1.ebuild
deleted file mode 100644
index dd39dce5ccf1..000000000000
--- a/sys-libs/libtermcap-compat/libtermcap-compat-2.0.8-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtermcap-compat/libtermcap-compat-2.0.8-r1.ebuild,v 1.14 2006/09/23 09:42:59 vapier Exp $
-
-inherit eutils multilib toolchain-funcs
-
-PATCHVER=0.1
-
-MY_PN="${PN/lib/}"
-MY_PN="${MY_PN/-compat/}"
-MY_P="${MY_PN}-${PV}"
-S="${WORKDIR}/${MY_P}"
-PATCHDIR="${WORKDIR}/patch"
-DESCRIPTION="Compatibility package for old termcap-based programs"
-HOMEPAGE="http://www.catb.org/~esr/terminfo/"
-SRC_URI="http://www.catb.org/~esr/terminfo/termtypes.tc.gz
- mirror://gentoo/${MY_P}.tar.bz2
- mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="freedist"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc sparc x86"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
-
- cd ${WORKDIR}
- mv termtypes.tc termcap
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/tc.file
-
- cd ${S}; epatch ${FILESDIR}/${PN}_bcopy_fix.patch
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
-
- epatch ${FILESDIR}/${P}-fPIC.patch
-}
-
-src_compile() {
- emake prefix="/" CFLAGS="${CFLAGS} -I." || die
-}
-
-src_install () {
- dodir /$(get_libdir) /include /usr/$(get_libdir)
- make prefix="${D}" OWNER="root:root" install || die
-
- # Conflicts with ncurses.
- rm -rf ${D}/include
-
- cd ${D}/$(get_libdir); mv libtermcap.a ../usr/$(get_libdir)
- # Make sure we link to /lib/libtermcap.so, not /usr/lib/libtermcap.a,
- # bug #4411.
- gen_usr_ldscript libtermcap.so
- dosym libtermcap.so.2 /$(get_libdir)/libtermcap.so
- dosym libtermcap.so.${PV} /$(get_libdir)/libtermcap.so.2
-
- cd ${D} ; rm ./lib
-
- insinto /etc
- doins ${WORKDIR}/termcap
-
- cd ${S}
- dodoc ChangeLog README
-}