summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2006-10-05 00:41:21 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2006-10-05 00:41:21 +0000
commitd3e3904c56d2b8766865825cd20da46bb7baae7d (patch)
tree5ebf9816fca19e8bc3213bfe6afa85f7ed7a03cf
parentVersion bump to 1.8. (diff)
downloadgentoo-2-d3e3904c56d2b8766865825cd20da46bb7baae7d.tar.gz
gentoo-2-d3e3904c56d2b8766865825cd20da46bb7baae7d.tar.bz2
gentoo-2-d3e3904c56d2b8766865825cd20da46bb7baae7d.zip
Added 2.4.0 release.
(Portage version: 2.1.1)
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.4.0.ebuild115
-rw-r--r--dev-lang/R/files/digest-R-2.4.03
3 files changed, 124 insertions, 1 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 587247cf6dde..939f442c64eb 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.77 2006/08/07 12:51:34 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.78 2006/10/05 00:41:21 kugelfang Exp $
+
+*R-2.4.0 (05 Oct 2006)
+
+ 05 Oct 2006; Danny van Dyk <kugelfang@gentoo.org> +R-2.4.0.ebuild:
+ Added 2.4.0 release.
07 Aug 2006; Ferris McCormick <fmccor@gentoo.org> R-2.2.1.ebuild:
Stable on sparc --- Bug #135318 --- has been running fine since last January.
diff --git a/dev-lang/R/R-2.4.0.ebuild b/dev-lang/R/R-2.4.0.ebuild
new file mode 100644
index 000000000000..2210ee78bb75
--- /dev/null
+++ b/dev-lang/R/R-2.4.0.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.4.0.ebuild,v 1.1 2006/10/05 00:41:21 kugelfang Exp $
+
+inherit fortran toolchain-funcs flag-o-matic
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas jpeg nls png readline tcltk X lapack"
+
+RDEPEND=">=dev-lang/perl-5.6.1-r3
+ readline? ( >=sys-libs/readline-4.1-r3 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ png? ( >=media-libs/libpng-1.2.1 )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ tcltk? ( dev-lang/tk )
+ X? ( || ( ( x11-libs/libX11 )
+ virtual/x11 ) )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xproto
+ x11-libs/libXt
+ x11-libs/libX11 )
+ virtual/x11 ) )"
+
+AT_M4DIR="${S}/m4"
+
+pkg_setup() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ cd "${T}"
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77 or gfortran."
+ FORTRAN="gfortran g77 ifc"
+ else
+ FORTRAN="gfortran g77 f2c"
+ fi
+ rm -f test.{c,o}
+ fortran_pkg_setup
+
+ filter-ldflags -Wl,-Bdirect -Bdirect
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:-fpic:-fPIC:g" ${S}/configure
+}
+
+src_compile() {
+ local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh
+ --with-tk-config=/usr/lib/tkConfig.sh"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ econf \
+ $(use_enable nls) \
+ $(use_with blas) \
+ $(use_with lapack) \
+ $(use_with jpeg jpeglib) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with X x) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ rhome=${D}/usr/$(get_libdir)/R \
+ install || die "Installation Failed"
+
+ # fix the R wrapper script to have the correct R_HOME_DIR
+ # sed regexp borrowed from included debian rules
+ sed \
+ -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # The same kinds of seds are needed for these variables too, see bug 115140
+ sed \
+ -e "/^R_SHARE_DIR=.*/s::R_SHARE_DIR=/usr/$(get_libdir)/R/share:" \
+ -e "/^R_INCLUDE_DIR=.*/s::R_INCLUDE_DIR=/usr/$(get_libdir)/R/include:" \
+ -e "/^R_DOC_DIR=.*/s::R_DOC_DIR=/usr/$(get_libdir)/R/doc:" \
+ -i ${D}/usr/$(get_libdir)/R/bin/R \
+ || die "sed failed."
+
+ # R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ # the 2nd one is corrected by above sed, the first is replaced by a symlink
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../$(get_libdir)/R/bin/R /usr/bin/R
+ dodir /etc/env.d
+ echo -n \
+ "LDPATH=\"/usr/$(get_libdir)/R/lib\"" \
+ > ${D}/etc/env.d/99R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+}
diff --git a/dev-lang/R/files/digest-R-2.4.0 b/dev-lang/R/files/digest-R-2.4.0
new file mode 100644
index 000000000000..fe3365c6ec97
--- /dev/null
+++ b/dev-lang/R/files/digest-R-2.4.0
@@ -0,0 +1,3 @@
+MD5 f32379469d8712e9f5dd6435d30127d3 R-2.4.0.tar.gz 14597440
+RMD160 d4cc3257ab5fc6cfefd79877c64c0dff60ababb7 R-2.4.0.tar.gz 14597440
+SHA256 0a0263acf42230c291ca5cf371541077aae3a1f8a586e1bf336bdb6af76946e2 R-2.4.0.tar.gz 14597440